pfSense > USW-PRO-24 dropping clients

I just purchased a Ubiquity USW-PRO-24 switch. It is sitting behind a pfsense firewall. I am running the Unifi Console application on my MacBook Pro. The Unifi Console keeps showing that all of my “Clients” on all vlans have disconnected. So far the only way around that is to hard reset the USW-PRO and start all over. It then looses all of the clients again after a few hours. The other things happening are the inability to update the firmware on the USW and my networking isn’t consistent across vlans. My “Laptop” van works exactly as expect (even when the Unifi Console says it disconnected) but nothing else does. So, I deleted all of my networks except my Laptop vlan copied it and changed the DHCP settings. It isn’t working like the Laptop VLAN is. I am truly stumped. Previously, I had the pfsense running into a tl-sg108e (all DHCP servers are in the pfsense) and it all works like a champ. I am open to about any suggestion……

This is not an issues I have had before but here are a few things to try

  • Replace the cable between pfsense and the switch
  • Remove and re-adopt the switch
  • Update the firmware, even if the same version

I’m beginning to think I have a faulty USW. I have replace the cable, remove and re-adopted (several times) I have reset it to factory settings every time and still it starts dropping clients. The thing I’ve meant to tell you is that it will not update. I’ve tried 6+ times and failed everytime. I tried a few other ways since (cached and direct URL) and still nothing. Any other last suggestions? Thank you for your help!

Besides updating via SSH I don’t have any other suggestions.