PFSense + Unifi - Adding a VLan in cloud key

System : Router → SG2100/ PFSense 2.5 → Unfi Switch (USW16POE) → Cloud Key Gen 2+UAPAC+UAPNano

Works great, internet traffic passing no issues (thanks to Tom’s YouTube guides).

Set up VLans in PFSense, internet traffic passing no issues.

Set up 1x VLan in cloud key (Settings > Networks > Create Network), internet stops working.

On this last step, I just create the network and don’t apply it to any ports. This action seems to break the link between the USW and PFSense (the USW still routes local traffic - so devices plugged into the switch can still talk to each other - and PFSense also pings out to the internet, it’s just the connect between the two that breaks). Oddly power cycling the USW brings back the connection for about 60 seconds and then it drops again.

Any suggestions gratefully received.

Make sure you have the VLANs rules in pfsense configured properly to route traffic, I have a guide video here

Tom - many thanks for your response. It’s now working as expected and set out below the solution that worked.

I’ve been following this tutorial (along with your other one on PFSense

I have done a complete factory reset on PFSense and rebuilt along with adding VLans.

Everything worked up to the point of adding a VLan to the Unifi controller (without making changes to the ports so they all say “All”).

After some trial and error, restoring a back up (from earlier today) in the Unifi Controller and then adding the network solved the problem.

Not sure why this worked but thought I’d share.

Thanks for all your Youtube content, I wouldn’t have known anything about home networking without them!

1 Like