Pfsense strange behavior on PPOE

Hi there,

I have a very strange behaviour on my Pfsense.

It looks a lot like the problem here:

PPOE

BUT here is the funny part :slight_smile:

The whole setup worked with pf 2.2.xx or so. That was 4 years ago.

Now, when I try to do the same thing again, it does not work.

AND if I restore the old backup, it works ???

AND I took screenshots of every page in the setup and copied everything 1:1 to the new installation, but still no luck.

So in my case the Vigor is not the problem or at least there is a setting that is not available via the GUI?

At the moment I am deleting everything in the working backup until there is nothing but the bare installation and hopefully I will find a solution to this mysterious problem.

But if you have any idea where to look, I’d be very grateful.

UPDATE:
It gets even better :wink:

When I delete all the unnecessary stuff and finally run the PPOE setup wizard again, it fails?

So I made a backup before and after running the wizard and found that there is a difference in one line.

0
pppoe
pppoe0
re0
xxxx@xxxx.xx
--------ZH-----ub------=
yyyy

--------dH-----1b------=
on

Where “y” and “on” and the visible letters between the “-” are different.

Does this ring a bell or is it just a coincidence?
Regards, Dom

You are asking for trouble going through so many versions and expecting it to work !

I would upgrade through each version from your 2.2.x up to the latest version, seeing if anything is broken at each point.

If you just do a basic install with the latest release without restoring your old config and it works, then something changed somewhere. You could troubleshoot it or do a rebuild from a clean install.

Are you sure?

Because the old setup is working, not the latest one.

But the thing is, I have no idea where to start.

And even if I can find the setup that works in an older version, it won’t help me with my current setup, will it?

Because I can’t find the “wrong” setting in the current version.

Is there a way to compare log files or backups or something to find the problem?

If you have a working config and unworking config you can use notepad++ to compare the files

Pretty sure.

You have a working build on an old version of pfsense right, when you upgrade to the latest version it breaks.

So, unless you know what has broken, I would upgrade to the immediately next version and see if it works. You might get to the latest version and it works.

Or test the latest build with a clean install and see if it works, easy enough to do.

Inspect the logs to see what errors come up.

@neogrid Hmm I think I did not formulate my problem correctly :slight_smile:

The old config backup is working fine, probably on older pfsense versions as well as on the latest version.

BUT if I start from 0 with a fresh installation of pfsense it´s not working.

I might have a clue here, because of 100 of reboots I always see the message:

Configuring WAN interface..[fib_algo] inet.0 (bsearch4#26) rebuild_fd_flm: switching algo to radix4_lockless 

I did read that this function is not present anymore in pfsense, could that be?

Regards Dom

@Paul Yeah, I figured that out, but I can’t find anything suspicious here :frowning:

Update:

I just spoke to a network guy at my service provider and he thinks this sounds like a software bug in pfsense.

I will make a pull request to Netgate I think.

But if anyone knows how to set up the network for pfsense in a cli feel free to give me some advice.

Regards Dom

Oh ok I follow you.

PPoE is widely used in the UK, so I’d say if this was an error you’ll find loads of users with it. If you can’t get your hardware to play nice with the latest release it sounds like perhaps drivers, maybe you have something ancient that is no longer supported.

the BT DSL modems on ebay were very cheap and solved my issue. Out of curiosity who was the ISP?

Hi,

it is NetCologne.

Köln

Greetings Dom

UPDATE:
No solution yet but I want to check the WAN and LAN settings in Linux itself.

So can anyone pinpoint to the necessary files in pfsense? Or can I use the reglar BSD file strukture?

This one I, obviously, have to find out as well :roll_eyes:

So if anyone knows where to finde, help is much appreciated.

Greetings Dom

I did think it is /etc/rc.conf but apparently pfSense does something that makes the FreeBSD config obsolete. There is a line in that file telling you to not use it at all. After a bit more digging i found that the configuration is done dynamic. Not using static file content at all. Nice touch but makes it hard to troubleshoot straight from the OS because you ain’t going to see anything there. You can see that in this file /etc/rc.interfaces_wan_configure
I did expect pfSense just to fill/create files and let the OS do it’s thing. But they just made files that dynamic output the requested content when called. You could override that by creating /etc/rc.conf.local but i do not recommend that as a permanent solution only for trouble shooting.

@Leon: Thanks yes you are right and still there are a lot of conf files available once you get the cli connection. Here an expert should pinpoint the correct location please.

Furthermore I made an analysiis about the xml backups and found one interesting difference. Look at the screenshot.

I did not make any changes here nor do I know how to set these?

Any ideas?

Greetings Dom

OP your old config is associated to the old firmware format. So you cant load that old config on a new firmware version.

But Im curious: PPPoE is a 1-click operation + you have to enter the user & pwd info. Why don’t you just recreate the config manually on the interface?

Well exactly this did not work. The one click operation …

BUT. I found the solution: First one who makes the right guess gets a free beer!

Promised :slight_smile:

So I will give 24h for your ideas – be creative :wink:

Hmmm … doubt the problem is related to pfSense not working as it ought to be. I’d guess it’s back to your modem, the only thing that might change is the MTU, you probably set that to a value below 1520 the default in the Vigor. PfSense has a default of 1500 so your modem cannot be lower.

Same thinking here that maybe the MTU size was to big but that makes no sense i think you set the same setting in the old version as in the new version. If you did not then it is just user error. Same for the mac spoofing if that is needed for your ISP (have not seen that needed in ages). And i know its rare but the service name can be set to null instead of a empty string. But again then you configured the old version and the new version different. I still think you trying to point ti something that is changed in pfSense that we are missing…

OP, if you manually create the link it doesnt work?
Are you using the right interface? User and pwd?
MTU has nothing to do with establishing the link - it will impact only the speed has packets need to be fragmented.

Ok here is the great finally :slight_smile:

I guess Leon got the most accurate answer, because it was the old MAC address of the former Router which was still in place at the ISP ( So kind of a user error at the ISP).

So give me a PM and we will see how to get your beer :slight_smile:

I´m still confused why this strange behaviour is happening.

Greetings Dom

PS: Thread closed