Pfsense PPPoE connection times out after 9 seconds even after receiving PADO

I use TP-LINK VR600 instead of my ISP provided router, it supports bridge mode.

My country uses PPPoE & VDSL over a copper telephone wire.

DHCP is disabled on the VR600 and it’s subnet is, pfesense is

Not behind a CG-NAT, I checked.

I tried having the router in bridge mode (basically adding another WAN interface and having it in bridge mode) and removed the PPPoE WAN interface. Changed WAN type in pfsense to PPPoE and added my line details, but it times out trying to connect to PPPoE and keep retrying.

I did a pcap and opened it in wireshark, it keeps going like this, 3 PADI 1 PADO received and the difference between the first PADI and first PADO is 10 seconds every single time. So as 9 seconds passed pfsense keeps sending PADIs and rejecting the PADO it received for the first one.

I tried to contact my ISP (they are crap) to speed up authentication but they have no idea what I’m talking about. I also tested a broadband dial-up on my Windows PC plugged directly into the modem/router in bridge mode and it worked fine. Also the router itself works in PPPoE so the problem is the stupid 9-seconds timeout that I cant override. I tried reaching out to pfsense support and they basically say we don’t know and there is no way to override the timeout.

So I just wanna know if there is no way to get this working then?

I tried for more than a week to get anything from anyone at the pfsense forums but no one is giving me anything useful

Any help? I know it’ll work with double NAT but it not optimal.

Thanks in advance!

Can anyone help? I really cant find support anywhere