pfSense / OpenVPN - DNS over OpenVPN

Hello, I see this is a common problem but I’ve been unable to find a solution or answer my specific questions.

I cannot resolve my local DNS names when I remote into my network through OpenVPN. I’ve tried different settings but I can’t seem to get it to work.

Is this something that should be configured in the DNS Forwarder?

Inside DNS Default Domain I originally put my WAN address but that didn’t seem to work, so I tried putting my hostname and domain that didn’t seem to work either.

Doesn’t the DNS server on my pfsense have an IP address?

Which setting within the Advanced Client do I need to configure to get my dns resolver to work over OpenVPN?

I only have three domains proxmox.lan, actual.lan, pfsense.lan.

You need to apply an ACL of the OpenVPN subnet in your resolver settings. Like this

I did that and included the Tunnel Network that my OpenVPN uses and it didn’t work.

Looks like you set in the DNS Default Domain. It should be

Also you didn’t specify DNS server in you configuration after enabling DNS Server enable. Make sure to supply the interface IP. In my case it was


I still haven’t been able to get it to work. I change the DNS default domain as specified to, and I tried my gateway for my firewall which is and I also tried my WAN address and that did not work either.

Do I need to do a new client export each time I change the DNS settings within OpenVPN? Within the DNS Resolver my private domains are setup within Host override.

I also have TLS/SSL enabled with a few options checked. Does that make a difference in what needs to be done?

Shouldn’t my DNS Resolver have a specific IP address I need to put into the OpenVPN configuration?

I figured I would try and turn the below options on as they mention OpenVPN but that didn’t seem to do anything.

My OpenVPN tunnel network is set to I set the Access List to allow for this network.

This is how I set my DNS in OpenVPN.

Under DNS Server 1 I have tried,, and my WAN address. I access my firewall through

OpenVPN is working and I’m able to access everything through their IP addresses I just cant resolve my private domains.