Pfsense openvpn client connected to private internet access (1198) using port 443

Hello,

I’m trying to setup a openvpn client connection on pfsense box connected to private internet access (port 1198). The internet connection I’m using only has port 80 and 443 open through the firewall. Can this be setup through port forwarding to forward port 1198 to go though port 443 using TCP ? Can this even be done ?

1 Like

Not sure what you mean. The client on your pfsense is connecting outbound to 1198. You don’t need any NAT rules.

1 Like

The only open ports on the firewall are 80 and 443. If port 1198 is connected on the outbound, but the port is blocked on the firewall how could I redirect traffic from 443 -> 1198 or maybe it would be from 1198 -> 443 ?

When I go to test port 1198 in pfsense “test port”, it basically just sits there and timeouts.
When I use 443 it is successfully.

Hopefully that makes sense.

1 Like

Doesn’t sound like you’re going in the right direction … you probably have a config error somewhere in your OpenVPN client for PIA, I don’t use them but it should be fairly straight forward

1 Like

Yeah I mean if you followed the documentation you shouldn’t have any issues. I had this setup a time ago and had no issues. Make sure you have the right CA’s downloaded and imported correctly with the corresponding port number in your list.

1 Like

I think I might have found my answer…

https://docs.netgate.com/pfsense/en/latest/vpn/openvpn/sharing-a-port-between-openvpn-and-a-web-server.html

I believe the option under the client setting for openvpn using the http proxy may be the answer…

Thank you both, xMAXIMUSx and neogrid for your input and responses, it was much appreciated. Thought I would share the info with you just in case you would run into a similar issue in the future and perhaps help someone else out.

Nice work! I’m glad you got it resolved :slightly_smiling_face:

I haven’t quiet tested it yet :wink:, but when I do I will post if it works so everyone knows.

I’m a little confused on the instructions on the page though… at one point the first thing to do is setup a openVPN server on port 443, and add a firewall rule to pass on port 443… And then a little later it mentions…
“In the custom options of the OpenVPN instance, add the following:
port-share x.x.x.x 443
Where x.x.x.x is the internal IP address of the web server to which the non-VPN traffic will be forwarded.”

I’m assuming that’s on the client side of openVPN ? Also… then it mentions a internal web server ?

Guess I’ll take it one step at a time and see what works… :wink:

I’m not seeing anything in there about creating a openvpn server… are you sure you are looking at this documentation?

https://www.privateinternetaccess.com/helpdesk/guides/routers/pfsense-2-4-5-openvpn-setup