Pfsense on Virtual box does not like to resolve names with DNS [SOLVED]

I’ve setup pfsense on Virtual box and for some reason the DNS resolution does not seem to be working unless i have the gateway (of the physical router outside the vm) added into the DHCP server. Ping seems to be working from the pfsense box but not from the client.

Any help would be appreciated.

I don’t see any DNS servers in your screenshot and unless the DNS sever is on the same local network then it needs to use the gateway to get out.

The dns server shown in the ipconfig is the pfsense. Since pfsense is able to resolve shouldn’t the requests from the clients be processed as well ?

Moreover the “Allow DNS server list to be overridden by DHCP/PPP on WAN” has been checked so wouldn’t that mean the pfsense would use the DNS from the WAN interface.

Try putting in in that page for DNS and see if it works.

1 Like

Adding the routers IP to the DNS server in LAN>DHCP Server works but is that the correct way to do it. Wouldn’t that bypass the pfsense if i want to force all DNS queries to go through pfsense.

Following your video on blockin all DNS queries and adding replacing the ‘pass’ rule with a custom one solves it but just need to know if that is how it should be done.

My video on blocking DSN is accurate, so if that is the goal then you are good.

1 Like

Thank you. So why does’t the client resolve the address when pfsense does it. The client only resolves when using the routers IP

Hard to say, it should work with just the default settings on LAN.