Pfsense ntopng not working

I was looking for a way to implement bandwidth monitoring on my pfsense. I was watching Lawrence’s video “How to Configure Traffic Monitoring with ntopng on pfsense” Things were going fine until I tried to access the interface on port 3000 and nothing was working.

Next was to dig more and see what the issue might be, I found the ntopng service stopped, I started it and less than a minutes later it stopped.

So from running ntopng from shell I am getting below

06/Mar/2022 09:43:14 [Ntop.cpp:2493] Setting local networks to,fe80::/10
06/Mar/2022 09:43:14 [Redis.cpp:99] ERROR: Connection error [Can’t assign requested address]
06/Mar/2022 09:43:30 [Redis.cpp:148] ERROR: ntopng requires redis server to be up and running
06/Mar/2022 09:43:30 [Redis.cpp:149] ERROR: Please start it and try again or use -r
06/Mar/2022 09:43:30 [Redis.cpp:150] ERROR: to specify a redis server other than the default

I did some Googling to find possible solutions, I didn’t find anything that helped fix my problem. I did some reading on radis from package link FreshPorts -- databases/redis: Persistent key-value database with built-in net interface

I did add this redis_enable=“YES” in /etc/rc.conf.
Power cycled PfSense and having issues.

I did run redis-server manually from shell by using command redis-sever then I started ntopng and it stopped after a minute or so.

I didn’t play around with redis config and didn’t create any other specific config for it to run with ntopng as I am not sure what it needs exactly. The config path is /usr/local/etc/redis.conf

In the whole process, I did remove the package and re-install it, power cycled PfSense multiple times and still getting same problems nd not sure what to do. Any help would be much appreciated!

For what it’s worth, I am having the same problem. Ntopng keeps stopping on me. For me though it runs a little longer than a few minutes. I haven’t had the time to investigate yet.

I Have found a workaround from the netgate forum It says to remove the .rdb files from /var/db/ntopng/. I also tried to remove the package and reinstall it to no avail.

It seems to be a bit buggy since the last update. Works for a few days then has to be reset or you end up getting “You’re not supposed to be here! Internal server error” when clicking on host. I have not dug into why but their forums would be the best place for that.

Is there an older more stable version that I can perhaps install? If so then how would I be able to do that with having dependencies installed as well?

Spent the last few hours banging my head and still nothing too good but I think it might be an issue with redis possibly. I did run redis-server and then right after I ran service redis onstatus and found that it is saying redis is not running

Next thing that I found was when I do run ntopng I am getting Can’t assign requested address and when I try redis-cli ping I am getting same error message. Which again telling me possibly something wrong with redis

I got it to work temporarily by doing the following

1- Run redis-server with protected mode off

2- I had another shell going and gave it my Lan Address using the redis-server port
ntopng -r

3- Loading web on port 3000

I am having a problem determining which config files are being used to run both services so I can manually modify them manually so this would actually work.

I know these 2 file locations but doesn’t see that this is what’s being used since I manually modified protected-mode off in redis config listed in below and was still having a problem, same with loopback address in ntopng. So whenI do run the service from pfsense I am back to same issue since the service isn’t running the parameters correctly. At least that’s my theory.


So my temp solution was one of those. I have not done more testing to basically point to which one solved the problem temporarily but here you go. After any PfSense reboot try one of these methods.

1-Method 1
In Command Prompt execute 2 commands (* replace the with your LAN PfSense IP)

redis-server --protected-mode no
ntopng -r

2-Method Two
Install Shellcmd and then add 2 commands > same commands as above with changing your LAN PfSense IP

That actually didn’t fix my problem however I posted the 2 methods that can be used to run it in case having problems.

Since I posted my work around the service is still running will report back if i have any new info. Also if there are any logs from me you would like to look at just ask.

At least you got it running the easier way, so that’s good!