Pfsense not picking up the external IP after power outage

I have been having an on going issue when I have a power outage for whatever reason Pfsense don’t get the actually external IP from my modem. The Wan IP reported in Pfsense will either by blank or

I have been able to resolve this by unplugging my Pfsense router from the modem and resetting the modem. I wait for the modem to fully boot then plug pfsense wan port back in and the external IP gets picked up and the internet is working again.

I’m not sure if this could be an issue with the modem or if there is a way to delay Pfsense from querying the Wan port in till the modem has booted.

Thank you for any assistance and let me know if you need any more info.

This is more a cable modem issue than a pfsense one. If the cable modem issues a local IP while booting as part of it’s process then it should include a short lease time which would tell the device to ask again for an IP allowing enough time for the modem to boot.

1 Like

Interesting, This would make sense and thank you for the info.

Under Interfaces - Wan, in the DHCP client Configuration; you can reject leases from your cable modem if you know what it is.

I had this problem on Intel quad port card and resolve it with disabling WOL (Wake on LAN) on all Ethernet ports. If you don’t know terminal commands you can put your card in windows machine and in properties disable three WOL settings. I think there is three and one is disabled by default, but disable all WOLs.

Best Practice would be to add UPS power for the modem and Pfsense.