Pfsense - No Carrier

I was messing around with Sensei on Opnsense tonight because I was interested in maybe having pretty graphs to look at etc. Long story short I went through the install on there and as soon as it finished I had no access to my router via IP, so I figured no big deal I’ll just reboot it. No change on reboot either. So next step was reinstall the OS and restore a backup config, still no link on the interface. Reinstalled again just to be sure and still no link.

I have been on the fence about going back to Pfsense for awhile, and seeing that I was going to rebuild things from scratch anyways I figured hey why not reinstall tried and true Pfsense. So I install it from scratch and configure my LAN interface with the same assignment and IP as before, hit 7 on the console to ping something on my local network and it still doesn’t work. So I swapped the interfaces and I still ended up with one down.

So for hardware I’m running an old Dell Optiplex with a dual port Intel X520 card in it. The card if functioning fine as I still have my WAN interface on it, but the second port will not come up. Pfsense is showing no carrier when I look at interface status, and it has no link lights on the physical card.

I’m at a loss as to why that port is down - everything was fine until I installed Sensei - it’s almost like the interface was disabled in hardware or something. If I was moving things around I could suspect something at layer 1, but all I did was install a package on an OS.

Anyone have any ideas? I’m at a loss on this one.


Well I fixed it - need to do some more log review but bouncing the port on my switch seems to have fixed it. Not sure why it didn’t reset the port when I unplugged and the cables (and the SFP) though. Almost like my switch is a Cisco or something (it’s not, it’s an Aruba 1930).

Thankfully I have logs going to my Synology in the Log Center so I’ll see if I can find why tripped it. One of these days I’ll rewatch @LTS_Tom 's video on setting up Graylog and make it go.