PFSense Netgate 2100 , 802.1Q and Unifi switch question

Hoping someone may have a quick fix for this as I have not been able to resolve yet.

I have a Netgate 2100 that I turned LAN 4 into a logical port for LTE Failover. I know not the most preferred option but it does work. I have an 8 port Unifi switch in my lab that is connected to LAN Port 1 on the 2100. I have configured all of my Networks on the PFSense Box as well as DHCP and duplicated those networks on the Unifi controller as Vlan only. Uplink port on Unifi switch is set to ALL. I have the Switch port profiles assigned to the other ports on the unifi switch as needed to test.

My issue is when I enable 802.1q on the 2100 to create the logical port for the failover I no longer get any IP addresses for the networks assigned to the switch port profiles. If I set a port to ALL profile I get the default LAN address created on the Pfsense box. If I disable the 802.1q check box on the Netgate I can get the proper address per Network. Even custom profiles with Native assigned and several tagged work.

I’m hoping this is a small detail I am overlooking. Any assistance would be greatly appreciated.


They have a write up in the docs on how to set the ports:

Thank you for the reply. I did use the doc to setup the LAN 4 for LTE failover but by checking the 802.1q box it broke the normal Vlans from traversing the link to the unifi switch. Only default would work. It wasn’t until I added the tags that it started working. Didn’t realize I had to do this as well. Thought the VLAN setup would cover but I guess in VLAN mode it also need the correct tag. I appreciate your help.

1 Like