Pfsense Lan cannot ping VLAN


I’ve recently replaced my router with pfsense but i’m having an issue that i cannot seems to figure out.
My setup is Pfsense → Unifi Switch → Unifi AP.

My lan network is
My vlan 31 is
My Lan rules are the 3 default one. And for my VLAN 31 i only have a “allow all traffic” rule all for now.

In unify i’ve added the VLAN 31 and created a new Wireless network linked to this new VLAN.

Any computers that i connect on the VLAN 31 wifi network can ping device on my lan just fine but the opposite doesn’t work. From a device on the LAN i cannot ping device on the VLAN 31 and i don’t understand why. My LAN rules allow all trafic from LAN net to any destination. I’ve also try the ping command from pfsense but i get the same result.

Any idea what is causing this issue ?

Ping is on the ICMP protocol, add it and give it a go.

In pfsense when you create a new rule it defaults to “TCP” under protocol. Make sure you have that set to “ANY”

Thanks. I’ve tried and verified both suggestion but same issue.:

Here is what my LAN rules look like:

I was wondering since my LAN is my “parent interface” do i need to create a route for it to access the VLAN ?

Wow sorry guys. I’ve found my issue. My windows firewall was the one causing the issue. Once i temporally turn it down on both side it worked. I knew i shouldn’t check this out on a sunday :stuck_out_tongue: