pfSense interface stops responding

Looking for thoughts on how to troubleshoot or possible solutions to an on-going issue with my pfsense install. I have 2 physical interfaces in use (1 WAN, 1 LAN) and the LAN has 6 dot interfaces (vlans) attached to it. LAN port goes to a Mikrotik CRS326-24G-2S+ which serves all my devices including a UniFi NanoHD. Router Specs are below.

SuperMicro X11SBA-LN4F
CPU N3700 @ 1.60GHz
8 GB Ram
64 GB SSD Drive
PF: 2.6.0

Setup: I have ipv4/6 gateways setup with ISP. Not running PFBlockerNG and only DHCPv6. DHCPv4 is set to relay. OpenVPN server is enabled. Very little rule sets, and only a couple of PATs for outside services.

Problem: At random intervals (24h, 3-20 days), the LAN interface will just stop routing all traffic. No devices can reach gateway and unifi goes into isolation mode as well. The WAN interface is still working as I can connect from the outside to openVPN but I can no longer reach the web config from any network.

Temp Solution: I have a KVM connected to the box and the console still functions, so I issue normal reboot from the menu. When the pfsense comes back up all services return.

Things I have looked at or tried.

  1. I have shelled in on the console and run /etc/rc.d/netif restart igb1 which is the LAN port during the outage. Doesn’t help.
  2. I have tried to restart the web config from the shell, nothing
  3. I have run netstat -m during the outage and I see no errors around mbufs
  4. I have reloaded the config from backup and removed unused / unnecessary packages

I have been trying to figure this out for about 2 months now with no success. Any help or direction is greatly appreciated. TIA

Check dmesg and messages in /var/log/system.log for clues.

Reviewed both dmesg and system.log during times of traffic flow stoppage and see no errors or messages that seem to indicate a problem. Also I forgot to mention that when I pull up the console there are no messages shown there either.

My next thought is to move network segments and vlans to a different physical port to see if that makes any difference. I would think I would see some kind of errors but I am seeing nothing.