pfSense freezes on system update


I started the system update to pfsense 21.02_1 on my SG-5100 and it froze on the line:

[41/215] Fetching pfSense-pkg-Netgate_Coreboot_pgrade-0.29_1.txz

It’s been frozen here for about an hour now. The instructions explicitly say to wait and not leave or refresh the page until update completes. However, when I scroll through the logs, it’s all just prep work and fetching. I don’t think any packages have actually been modified yet. Just wanted to run it by you guys first and get a second opinion before refreshing and starting over? Suggestions?


Negate advice is to remove packages then do the upgrade.

Ok I forgot I have backups. I’ve tried restarting a few times and each time it hangs at the same place.

[41/215] Fetching pfSense-pkg-Netgate_Coreboot_pgrade-0.29_1.txz

Perhaps it’s on the wrong branch for updates … check system > update

Netgate DOES NOT say to remove packaged before the upgrade, they say “Do not upgrade packages before upgrading pfSense® software. Either remove all packages or leave the packages alone before running the update.”

When in doubt reload the device with the new version and restore from the backup you made just before the update. We have updated a few SG-5100 and they went fine.

Yeah, I haven’t upgraded any packages since before pfsense v21_02 was released so don’t think that is the problem. I am actually getting errors now though:

[44/175] Fetching libmcrypt-2.5.8_3.txz: … done
[45/175] Fetching libmaxminddb-1.4.3.txz: … done
pkg-static:,1.txz: No route to host

I hate it when the bug changes midway through troubleshooting.

When you say reload the device with the “new version” do you mean v21_02? Cause that’s the version I’m having trouble upgrading to.

Solved… Well… Kinda…

I just kept rerunning the update after every timeout, each time it would fetch a couple more packages until it eventually got all of them at which point the Netgate upgraded and restarted. I was back up and running in about 10 min.

Still, i wonder why it kept failing for “No Route to Host”.

Anyway, thanks for the comments.