Pfsense firewall rules & Plex in docker

So I decided to move my plex install to docker, to help streamline my setup.

Plex is working perfect, everything shows up like it should, no issues there.

However, on my Remote Access section, in Plex, it is reporting Plex is not accessible to the outside world. -

Head over to pfsense, check firewall rules, since I already had a Plex server, I changed the IP in pfsense, same port and everything. For some reason, it seems pfsense isn’t passing the traffic from my WAN to LAN.


I head over to a port checking website, to see if port 32400 is open, and it reports that it is closed.

Kinda at a loss as to what I need to check next.

Did you add a port forward rule under Firewall->Nat ? Also you just need tcp not udp .

2 Likes

I know it is a bit fickle trying to make get it working externally through PFSense, I had some troubles as well.

  1. Make sure your port forwarding is configured. Generally when you create the port forward, it will ask you if you want the firewall rule automatically created at the same time. Go ahead and do that. Only port you need to open is TCP and then whatever port you set Plex to.

  2. I found I had to add the following into the DNS Resolver settings, under Custom.

  3. I found that for Plex to work direct, and not in Indirect mode (limited to the quality you can play back to like a 2mbit stream or something) I had to go under System->Advanced, then Disable DNS Rebind Checks. But try without it first to see.

And finally, in Plex itself, try changing the port to something other than the one you want, apply the change, then change it back to the one you want, and apply the change. When troubleshooting mine, I had everything setup, and after flipping the port back and forth, it finally clicked.

I did not change that. I’ll make that change and try it again.

Made that change. Works perfect now.

Thanks for the idea!

@Manipulate can you tell me what your step 2. does? I don’t have this custom option set in pfSense and my Plex seems to work just fine.

I’m not 100% sure what exactly it does, but I believe it ensures that Plex client can make direct connections to the server, and avoid the indirect connections (where it uses a relay server, but quality is limited to 480p).

I don’t recall if this is the thread I read about it, but has some more details