PfSense Error. Help!

So PfSense stopped working. I restarted it a couple of times. It would take a long time to load so I would just restart it every time. I left it to run finally and after a full load, the network adapters weren’t showing. The above error is what I am getting now. I have set it up as a VM on Hyper-V. I think deleting the VM and restoring an earlier backup should solve the problem but I need to know exactly what this error is, and how it can be solved beyond a fresh installation.

Thanks.

Did this happen after an update? Because it seems like the config.xml is corrupted

The most recent change to the system was an upgrade to the current v2.5 in April. The system has worked fine since then until yesterday dawn.

Weird.
I think reinstall is the best way here, somehow your files seem to be corrupted?

Hello, i don’t have much experience with pfsense in a vm, but so far every time then i have problem with my NICs, it was a hardware problem. In your image it show many errors all looks like it having trouble “reading the disk” sense is a vm i assume the os is corrupted.
I don’t usually expend time trying to troubleshoot a pfsense, i reinstall it and restored from backup, is much faster easier and secure.
Hope it help you