pfSense DNS issue?


I’m very much an amateur when it comes to more advanced networking, but I ran into an issue today that I just can’t figure out.

I have a Netgate 3100 running the most current pfSense release. All my switching and APs are Unifi.

I woke this morning to discover no internet access on any of my devices. I was able to connect to the wifi no issue, but there was no internet connectivity. I reset the modem, 3100, and APs with no luck. Logging in to pfSense revealed all services green. There was nothing obviously wrong. No computers or phones were able to ping out, however pfSense was able to ping out no issue. My computer showed a properly assigned DHCP IP, but no default gateway. Releasing and renewing ipconfig solved the issue and restored connectivity. Doing similar on all individual devices in the house fixed it.

The question is - what happened? Any possible thoughts?

Thank you everyone. Happy to answer any questions, just don’t want this to get any more lengthy.

I’d look into the logs under Status > System Logs > System > DNS Resolver and see if there were any failures or errors. Might look at the DHCP logs also.

Unfortunately I couldn’t find anything beyond the max entries logged.

I have a logs being saved to my Synology however apparently the folder filled up and I was incorrect in my assumption that old files would be overwritten. Still figuring that out.

Even if you were offloading your logs I would think there should still be some of the most recent logs on the pfSense itself.

It would be helpful to know what DNS setup you are running, such as Forwarder or Resolver or if you have something like pfblocker in the mix. OS version and versions anything else installed.

I had something similar last year when I was updating DNS with DHCP leases, each time a new client would join DNS restarted and something in the DNS config would fail and the service would look like it was running but it was locked up. Only way to figure it out was getting into the logs.