Pfsense crapnetwork/openvpn


#1

hi,
I followed the video https://www.youtube.com/watch?v=HW9mUrF1ZgU pfsense and rules for IOT devices.
That is working but,

Wen i add the openVPN rules i have 2 gateways and then i can not ping the crapnetwork. And no chromecast etc…
When i disconnect de openvpn clent and i set all the gateways on * than it works again. (in the video you have to setup the gateways tot dhcp_wan).
I watched this video. https://www.youtube.com/watch?v=ov-xddVpxhc

my rules:

and my lan rules


local lan=192.168.0.0/24


#2

and this is my nat outbound.


#3

I think the problem is you try to reach an RFC1918 network going through WAN_DHCP gateway.
Try create an alias RFC1918 with 192.168.0.0/16 , 172.16.0.0/12 , 10.0.0.0/8 networks.
Then on your pass all rule on lan add destination is RFC1918 and check on invert match so it won`t match the rule.
If you want on the next rule you have add destination RFC1918 to be more specific and test if it works.

It seems like you want to push only achter_vpn through vpn. If so consider adding the route-nopull option on the custom options box on the openvpn client so it won`t force everything through vpn and you can still use the wan_dchp gateway without specifically adding it on the rule but with * if it is default.


#4

thanks tumpanaios.
I added the route-mopull option to the VPN client.
Everything is working now, and all the gateways have the * as defeault, except the ones witch go trough the vpn.