pfSense Configuration in VM no VM internet access

I installed pfSense in a VM on XCP-ng the server has one physical Nic so i set that as the WAN port on pfsense and added a virtual internal Nic for the LAN side all the other VMs connect to.

My issue is that the other VMs will connect to pfsense fine and get assigned an IP from pfsense however they do not have internet yet when loading the web configuration from a machine connected to pfsense virtually i can successfully resolve addresses like yet when opening a new tab and trying to go to from the same machine I can not access the internet.

When i had this same setup in virtual box it worked fine so I am thinking I do not have something configured correctly in either the virtual nic card or pfsense i attached a copy of my pfsense config file as it does not really containg any personal info (its just a lab project nothing production) hopefully someone can point out where I went wrong I want to get proficient enough with pfsense virtualy to be confident enough to deploy it as my main router OS.

Virtual pfSense config

Have you confirmed that the pfSense VM itself has internet access? Based on your config its Wan Interface is set to DHCP. It is possible that you are resolving from a cached entry, or possible the DNS server has another route to the internet.

Yes the pfsense vm has internet and I made sure it was not cached

Follow the guide and make sure you have added all the proper settings for the each network interface.

Thanks Tom I tried these and still had no internet so just for the sake of my own sanity, did a fresh install of pfsense and did these things suggested in that article first and now i get internet just fine so i must have had this issue along with something i changed.

But that is why we test in a virtualized space right :slight_smile:

Also made sure to take a snapshot of the pfsense vm since everything is working incase my tinkering breaks it in the future