PFsense config is massive

So here is a brain buster I can’t figure out, I made some changes to the OpenVPN and PFblocker last night I saved my changes and went to bed. When I got up this morning my internet was fine but when I tried loading the PFsense web interface if was giving me a 502 error. so I rebooted, it took forever but I eventually got internet once again but still no webpage, plus my 2 site to site VPNs were down as well as the one my devices connect to when away from home or need something that cant be accessed from wifi. so I drug a monitor down to my box and connected and watched it run thru it boot up. it started complaining that /var/run was full so I cleaned out the offending file which just logged the filter reloads and rebooted again this time it was complaining that the XML parser was out of memory. this had me stumped for a little while. I was going to restore a backup from the console menu but it would not load the options it also just errored. so I tracked down where pfsense keeps its backup configs and did an ls-la to show the what was there and found the screenshot below. I found that my config somehow went from using about 32k to using about 32M in about 17 hours. so I manually copied the first XML before I made the changes to the current config and restarted the box and have not seen the problem yet again. has anyone ever seen this happen or had it happen to them?

so it would appear that what actually killed the config was changing the PFblocker rules, but not sure how

That is odd, if you can get the but to happen again I would report it to the pfsense team,.