pfSense CE 2.70 - system is up to date?

Hello Community,
I am a bit confused that my pfSence CE 2.7.0 still says “The system is on the latest version” (non Netgate Hardwar device).

  • Also no update if i try the SSH (capture 13).
    Every update process said “The system is on the latest version”

I’ve checked the Netgate Portal, but that don’t solve my update issue.

Thanks for any kind of tip

Make sure you update the selected branch

got it :grinning: compared to the firewalls I have administered to date, there is room for improvement (potential upwards) :slightly_smiling_face:.

ZyWALL & Sophos Firewall post it directly in the Dashboard, and when you click on update, the device make an backup of the current configuration, download the firmware and proceed ths update include firewall reboot. :blush:

Thx for Support

That’s also how pfSense updates typically go. A notice shows up in the System Information section of the dashboard and you click on it to run the update.

I’ve had this same problem on one of my systems. My version train is set to latest stable release and had been bugging me to update for a while. When I finally had time to do that, I logged into the dashboard and it now says there is no 2.7.1 update. I figured there’s some glitch that will get sorted next time I check in.

EDIT: I just took a look at that system and it looks like it’s still stuck.

In my case, I first had to switch to V 2.7.1 under the “update settings” tab before I could carry out the update to 2.7.1
This irritated me, as my PfSense had never indicated an update in the dashboard. Fortunately, the update has now been installed without any errors.


In my case, I switched to 2.7.1 under update settings tab but it kept showing 2.7.0 and status Up to date, but now it apppears to have a new option 2.7.2 latest stable release. I’ll wait until I found out more about this.

I had to run the following command certctl rehash . I found this here


Thanks, problem fixed.

Thank you. That command worked on a couple of units but I still have one that refuses to download 2.7.2. Looking for and appreciate any other ideas.

I’m having the same issue.

**2.7.0-RELEASE** (amd64)
built on Wed Jun 28 03:53:34 UTC 2023

The system is on the latest version.
Version information updated at Sun Dec 31 10:14:25 EST 2023

My system update / update settings are both set to “current stable release (2.7.2)”. I ran the command certctl rehash in the GUI but there was no clear end. I opened a new tab and logged in to the admin and it did show 2.7.2 as available. I rebooted the system as is always recommended and now I’m back to the system is on the latest version. Did you not reboot after running certctl rehash?

Replying to my own comment in case it helps anyone else…

After re-reading the information here, I noticed it specifically says “until the next reboot”. So I re-ran the ‘certctl rehash’ and went back to the dashboard. I had to manually check for updates to see the 2.7.2. Proceeded with the update and everything is working now.

Run certctl rehash […] This will allow pkg to utilize the system certificates until the next reboot.

**2.7.2-RELEASE** (amd64)
built on Fri Dec 8 15:55:00 EST 2023

The system is on the latest version.
Version information updated at Sun Dec 31 10:41:21 EST 2023

I was having the same issue. Big thanks to Netadminuser! The command worked for me!