pfSense and USW48 VLAN DHCP not working

Hi Guys,
you have recommended the combo of pfSense and Unifi a couple of times. When I set up some VLANs on my Network (following your videos) I can only receive IP adressess on the Vlan1, all others do receive a DHCP timeout (obviously the DHCP feature relay does not work properly). The DHCP Servers are bound to the respective interfaces and are active.

Now, this seems to be a very common problem with configurations that aren’t featuring an USG, according to this post here in the Ubiquiti log: https://community.ui.com/questions/Disable-DHCP-Snooping-on-USW/47a417a8-f560-4924-a156-47e20e3a52c8?page=2.
The workound they are proposing is not yet working for me, maybe because the directory structure of the controller has been changed.

So I am wondering, what magic do you have up your sleeves that makes your VLAN configurations with pfSense and Unifi working like a charm in your videos ? Any hint would be greatly appreciated :slight_smile:

There is no magic, you create the VLAN’s in pfsense then match them in the UnFI system. Make sure the VLAN’s you create have the same number in both systems.
I cover the creation and firewall rules in this video.

Thanks for coming back so fast. This video has been guiding me through my setup, yet it did not work.
But after a day of investigation I finally found my mistake: Under /interfaces/switches/VLANs I had “Enable 802.1q VLAN mode” enabled" which prevented the passing of the VLAN tags. Idiot I am, I was thinking that I needed to switch this on to be able to work with VLANs at all.

So problem solved, maybe somebody else runs into this problem, so this is the solution.

Enjoy the day

Cu
Frank

1 Like