Pfsense and Ubiquiti Edgeswitch

About 3 weeks ago I switched our firewall from Untangle to Pfsense. I believe I have logged into my Ubiquiti Edge switches since the changeover, however, today I cannot seem to reach the web gui to log in to any of the switches. The switches are all working fine, I just can’t reach their web gui’s. I have tried from multiple web browsers and computers and operating systems. So it seems that the problem may be with the firewall. As far as I can tell, I do not have any rules that would block access to the IP addresses for the switches. I can ping the switches just fine. I have tried restarting 1 of the switches, that did not help. I have 8 Edge switches, 7 UNIFI switches, 1 Aggregation, and 1 Cloudkey.

General Network info:

Edge and UNIFI Switches and access points are on same subnet/vlan
I have other vlans for:
Security Cams
Student ,This is the only one that is locked down tight and has pfblockerng running on it.

Any thoughts on what rule or setting might cause me not to be able to hit web gui’s for Edge switches?

Thank you in advance

The computer that you are trying to connect to the Edge switch web ui is it on the same subnet and vlan?

Yes, it is.

If this is the case then pfsense should not interfere with the traffic because it is in the vlan/subnet. Are you able to ping the IP address of the switch?

Yes, I can ping all of the edge switches, and they are moving traffic correctly. I am only thinking it might be the firewall, because the problem is global. By global, I mean that it is not machine, OS, or Browser dependant, no matter what I am using to hit the gui, it won’t connect.
Screenshot 2023-04-27 193824

I assume your switch’s IP address is set to static, how about setting your computer to a static IP address and then just connecting your switch and your computer no other devices connected. See if its able to open the web gui.

All my switches are set to static. One of the edge switches is right next to me and my computer is connected to it. Since all of my switches are in a production environment, I cannot disconnect everything except my PC. The fact that I can ping all of them, suggests that the problem is not a layer 2 problem.

Have you tried running wireshark while trying to access the switch web gui? Is it possible to share the results with us?