pfSense and Multiple Xbox Ones: Open NAT Guide

Upon turning on my Xbox One after several months, I was greeted by “Strict NAT” (which only allows you to play and communicate with “Open NAT” players and prohibits you from hosting games) when trying to play. My son had complained some time ago about seeing “Strict NAT,” so I enabled UPnP for the gaming VLAN, which at least got him to “Moderate NAT.” After reading several bulletin boards and watching multiple YouTube videos on the subject, I finally got “Open NAT” on both Xbox Ones. Here is how I accomplished it in pfSense:

  1. Services > DHCP Server > VLAN_for_your_gaming_devices; create static entries for your Xbox One(s). If you haven’t created a separate VLAN for your gaming devices, stop here and refer to one of @LTS_Tom’s videos on how to do that in pfSense… never enable UPnP on a “flat” network.

  1. Firewall > Aliases; create an entry for your Xbox One(s).

  1. System > Advanced > Firewall and NAT; change “NAT Reflection mode for port forwards” to “Pure NAT” and check “Automatic create outbound NAT rules that direct traffic back out to the same subnet it originated from” (this allows multiple consoles to join the same server).

  1. Firewall > NAT > Outbound; create an entry for your Xbox One(s):

Notice the “/32” subnet mask. Make sure “Static Port” is ticked.

  1. Firewall > NAT > Outbound; tick “Hybrid Outbound NAT rule generation. (Automatic Outbound NAT + rules below).”

  1. Services > UPnP and NAT-PMP; tick the first three boxes, highlight only your gaming VLAN, then tick the “Deny access to UPnP & NAT-PMP by default” box.

  1. At the bottom of the same page, create rules similar to these:

For those three lines under “ACL Entries,” I actually “stole” those from the config.gateway.json file I used with a UniFi USG Pro for the same issue (Open NAT with multiple Xbox Ones). Note that you want to block port 3074, which forces the Xbox One(s) to use different ports for Xbox Live and allows multiple Xbox Ones to have Open NAT. This rule must be the first entry in the list. The “/24” applies the rule to the entire subnet. The “/32” in the other two entries indicates individual hosts, which are the only ones on the network allowed to access UPnP (this overrides the “Deny access to UPnP & NAT-PMP by default” setting in step 6).

  1. Make sure your Xbox One(s) is/are completely shut down (when in doubt, unplug it/them). In pfSense, Diagnostics > States > Reset States; tick the “Reset the firewall state table,” then click on the “Reset” button. You’ll need to re-connect to pfSense after that.

  2. Turn on your Xbox One(s) and wait for them to boot. In pfSense, Status > UPnP & NAT-PMP, you should see entries similar to this:

Enjoy your “Open NAT” and the ability to play in the same server (if using multiple Xbox Ones).

Some games also require additional ports. I remember playing Call of Duty Infinite Warfare; it also required port 3076, and I was only able to obtain Open NAT (this was with a UniFi USG) on one console at a time (the other indicated Moderate NAT) while in the actual game. The Xbox Ones themselves, however, indicated Open NAT.

Here is a list of ports used by various Call of Duty games:


This is similar to how i go a Moderate NAT for gaming on PC when i still played games, yours is a bit further in depth then what i did but you also got to open. im certain that other then having to discover the ports this should work for most nat related issues

I am going to try this as soon as I get home! I have spent a whole year trying to get this to work right. To this day I am able to get both Xboxes to show open NAT but when both of them cannot successfully join a game together on several games (Apex COD to name a few).

I believe that deny entry is what I missing all along. I am so excited to try this. Thanks so much for the time you put into making this!


Step 3 is what enables multiple consoles to join the same server; I just edited the original post to “reflect” that.

Would this work if I used manual outbound NAT instead of hybrid? Is it safe to assume that doesn’t matter as long as the actual rule is correct?

I followed your steps to the letter and I’m still getting moderate. I wonder if it could be anything else. I’m not seeing any snort alerts. Anything I’d need to do with my switch?

Do you have any other firewall rules for your gaming VLAN? I also only got Moderate NAT until I disabled the RFC1918 rule I had in place.

The “Block XBN to LAN” rule could be the problem. Disable that rule, completely shut down your Xbox Ones (by holding the power button until they shut off), and in pfSense, Diagnostics > States > Reset States; tick the “Reset the firewall state table,” then click on the “Reset” button. I mentioned an issue with a similar rule in my third post in this thread.

1 Like


I’m glad you figured it out, and thanks for posting the steps you took to get it working. I’m having “Strict NAT” issues with the “Xbox Console Companion” that’s included with Windows 10:


I tried changing the ports as described here, yet “Strict” is still indicated. pfSense shows the port being used (54026 is the port [among others I tried] I set, using the instructions in aforementioned YouTube video):

I’m not particularly concerned about it, however, since I’m only using the Windows app for chat and such.

1 Like


If you have multiple Xbox Ones on your network, another option to achieve Open NAT (in lieu of blocking port 3074 in the UPnP rules) is to set the ports manually on the consoles themselves:

Network > Advanced settings > Alternate port selection (make sure the consoles are all set to use different ports)

1 Like

Ok I was really dumb. I use an openwrt router as an ap and another as a repeater. I somehow forgot to disable the firewall, DHCP and upnp services from starting on the openwrt ap :triumph: :face_with_symbols_over_mouth:

This whole time I’ve been troubleshooting, encrypting my DNS, worrying about conflicting firewall rules. It was all because my wireless AP was creating a double firewall :man_facepalming:t2:

Good news:
I am able to achieve an open nat on both consoles with automatic port mapping WITH my [deny vlan -> lan] rule, as well as my [deny vlan -> openvpn] rule.

I also found out through my testing that open nat also works with encrypted upstream DNS!

So not only is the nat open for both xbox’s; they’re being routed to a privacy-friendly anonymous encrypted DNS server (, through an upstream encrypted TLS tunnel with zero DNS leaks to my ISP. The vlan is sandboxed completely from openvpn and the lan network giving me the most secure setup. :fist:t2:

How to achieve an Open NAT for PfSense + OpenWRT users:

If you’re using an OpenWRT router as an AP with your PfSense environment like me, Go to the LuCi configuration page for your AP. Make sure that dnsmasq, firewall, and odhcpd are all set to disabled in system -> startup. Then go to Network -> DHCP and DNS -> make sure ‘Authoritative’ is checked, hit save and apply. Then reboot the AP. Do this for every OpenWRT repeater you have as well, otherwise you’ll get stuck with an unavailable nat.

This works 100% of the time for 2 Xbox One’s (Xbox One S and Xbox One)

Update for Open NAT with OpenWRT AP

Don’t forget to also disable sysntpd from startup in system -> startup inside the LuCi configuration page, and reboot OpenWRT afterwards. Do the same for every OpenWRT repeater you have. Was causing ntp conflicts with the parent pfsense interface.

I come here with one final tip for you guys.

Setting the pfsense firewall’s congestion algorithm to “Conservative” seems to keep the NAT open indefinitely.

I came across this solution from another user on a different tech forum. Nonetheless it works. You can even leave the Xbox One on power saving mode, no long startup is necessary, no toggling wifi. It just works once the NAT is made open.

Thanks for the additional information, @TheAlmightyOgreLord. I have a feeling this thread will [unfortunately] get more views in light of current events.

1 Like

Here is what Xbox Live looks like in Wireshark:

Notice the “Port A” column, which would normally indicate 3074.

1 Like

Excellent write-up!! I am having issues getting any of it to work consistently though, and I’m no dummy when it comes to this stuff. I will only see UPnP connections from time to time, it’s not consistent at all. It seems to just do straight up NAT Outbound and disregards my UPnP rules.

I play Destiny 2 among other things which works fine until we try to team up in the same game. There are 3 gaming PCs, an Xbox One, and an XBOX 360 on network among a whole slew of other non-gaming type devices.

I have denied ports 3074 and 3097 via UPnP. Outbound NAT is wide open though for my gaming devices.

It baffles me that this doesn’t seem to work. I have even excluded the port that I am blocking from the Allowed ranges:

The game shows it as moderate NAT on port 3074:3074; the exact port I am trying to block. The States table (cleared before testing) shows that as being true. What the heck is going on?

This is frustrating, I hope you have some insight!

Did you separate the Xbox to a physical VLAN port? It’s known that if you use an Xbox One on the same physical network as your other devices with different firewall rules, it will use uPnP to ignore the firewall rules you set.

I achieved this seamlessly by using an OpenWRT router of mine and two separate WiFi networks through the built in switch on the consumer router.

It is also known that one Xbox of the two will say the port is unavailable but is indeed being forwarded ports 0-65535, and play online as if it has an open port. The other Xbox will say open.

Also you don’t need to exclude the port 3074 from the allowed ranges, since the first rule you have being executed is to deny 3074. It overrides the below rules, making your setup redundant… The Xbox needs the port range open to trigger an open nat

I have actually completely redone my network configuration. I run 4 VLANs now, LAN, GAMING, IOT, and DMZ. UPnP is only allowed on LAN and GAMING (soon to remove from LAN). It’s still a bit strange how it behaves, but at least I’m getting some UPnP action and Moderate/Open NAT for most things. I’m happy with how it’s performing, yet I’m still interested in figuring out why it doesn’t like to obey the UPnP deny entries.


There’s no longer a need to block 3074 in the firewall:

In the Xbox One interface, Network > Advanced settings > Alternate port selection (make sure the consoles are all set to use different ports)

Also, I see from your screenshot that “Deny access to UPnP & NAT-PMP by default” is not checked; you should check that so only authorized devices can use UPnP.