Pfsense 2.7 and DHCP to HP printer

I upgraded my pfsense firewall from 2.6 to 2.7. Once I had pfsense up and running again, I noticed my printer was throwing an error. I did my normal troubleshooting and determined that my printer was toast.

I went out and bought a new one, a HP DeskJet 4152e. I followed the directions to get it added to the wifi and had it join. Well, that is when the fun started…

Once the printer gets the dhcp connection and receives the IP, at least that is what I think is happening, the print crashes. All the lights on the control panel and display start flashing and it is not accessable from the USB connection or its internal wifi.

Where do I need to look for what is wrong. I feel its with the dhcp/arp that is causing the issues.

Once the print is toast and errored out. I do not see its mac address in the arp table.

Do you have any idea what my next steps will be? Let me give you a list of the things I have tried.

  1. Removed my DHCP reservation for this mac/ip address and tried. No luck. DHCP set to Allow all connections. I wanted the DHCP server to assign a new IP.

  2. I set the DHCP server to Allow only known interfaces and I assigned mac and IP to my printer to the DHCP Server. I restarted my printer and added it to the wifi. No luck.

I am at a loss now as to how to get this to work. I am sure there is something with the 2.6->2.7 upgrade that caused this.

Anyway, any help at this point would be great.

I would have a really hard time believing DHCP crashed your printer. Now what I really think happened is when it connected to the internet it might have tried to download and install firmware updates and crashed.

1 Like

I have a guest network that runs on a completely different small router. When I attached the printer to this network, It all worked as normal. The printer attached and did not have an issue. I changed it to my normal “Home” Wifi and BOOM! The printer crashes when it calls for an IP.

I agree that I would not think DHCP is the culprit but it sure starts looking like that. I think its something in the new pfsense 2.7 release and a setting that needs updated.

In any event, have a great 4th of July and thanks for the response.

Ok, I found the issue. It was pfsense and the firewall/NAT rules. I found several rules that used IPv6 and IPv4 protocols. My network only uses IPv4. I removed that protocol and then tested the printers. BOOM! They both joined the network and all is fine now.

Thanks for the help anyway.