Pfsense 1+Gbps uplink

Just got the Optiflex 2030 from eBay and the new Intel I225-T1 network card for it.

Recently upgraded my cable modem to Netgear CM2000.

The network cable between pfsense I225-T1 interface and the modem is a short, factory-made CAT 6A cable, pfsense reports the correct link rate: WAN 2500Base-T full-duplex.

The Xfinity plan is 1200MBps.

When I ran the speedtest (on the pfsense itself since I haven’t upgraded my LAN’s hardware yet), I’m still getting 940-ish Mbps as before.

What I could be possibly missing?

PFsense 2.6.0 CE, speedtest was measured prior to enabling ntopng and other goodies.

You have an I225-T1 for the WAN interface. What interface do you have on the LAN side? If it is only 1Gbps, you will still only see 940 Mbps approx on the client side.

You are witnessing network overhead.

While I (temporary) have 1Gb NIC on the LAN side (that’s a future upgrade), I’m running the speedtest binary straight on the pfsense box, so only WAN NIC speed matters, I believe.

If that’s network overhead, it doesn’t make sense - I’m getting about the same numbers (in the 940ish range) as before. Where did additional 200Mbps went into?

Not sure if this applies in your case but I have experienced a limit due to cpu. Especially when running ids/ips (ie. snort or suricata) or other systems that inspect the packets more deeply. Once I upgraded to a device that had a cpu with more performance I was finally able to exceed the 1gbps over my 2.5g wan port.

Well, I got a multi-gig adapter from Amazon today and tested the line speed right away - everything looks up to specs:

   Speedtest by Ookla

      Server: Comcast - Seattle, WA (id: 1782)
         ISP: Comcast Cable
Idle Latency:    16.12 ms   (jitter: 12.52ms, low: 10.61ms, high: 35.13ms)
    Download:  1352.50 Mbps (data used: 1.3 GB)
                 17.27 ms   (jitter: 3.49ms, low: 5.08ms, high: 51.38ms)
      Upload:    40.76 Mbps (data used: 54.7 MB)
                 26.50 ms   (jitter: 13.16ms, low: 6.92ms, high: 429.70ms)
 Packet Loss: Not available.
  Result URL:

Then I ran the speedtest script (which is I believe a different one comparing to my laptop) on PFsense again and got what I expected by eventually trying out different Speedtest servers:

: speedtest --no-upload --server 21653
Retrieving configuration...
Testing from Comcast Cable (IP REDACTED)...
Retrieving server list...
Retrieving information for the selected server...
Hosted by as26370 (Lopez Island, WA) [92.83 km]: 15.456 ms
Testing download speed................................................................................
Download: 1231.05 Mbit/s
Skipping upload test

Based on my quick observations, multiple Speedtest servers could be busy/not up to max speeds to be able to properly test 1+Gbps speeds

1 Like

The Netgear CM2000 is a DOCSIS 3.1 router for Coax, and has a 2.5GE WAN port that you connected (if I understand correctly) your Optiplex to it

To what do you run iperf with pfsense exactly?
If it is toward your LAN, it is normal you get 940Mbps since you havent updagrade your PCs yet.
If it is towards to Internet, servers with iperf service are not always adequate so be careful with results you can see.

I ran the speedtest binary instead of iperf directly on the PFsense box