pfblockerNG and Mullvad VPN

I’m trying to get pfblockerNG to work this Mullvad VPN.
I have successfully followed the Mullvad VPN pfsense guide here: There are no DNS leaks and everything works as it should.

I’ve also installed pfblockerNG on my pfsense router, launched the wizard, selected the interfaces requiring blocking but no ad blocking seems to be working.

I believe it might be something to do with the DNS servers Mullvad gets you to use in their instructions, but I’ve poked around and tried a few different settings on both the pfblockerNG side and DNS settings, all to no avail.

Any help would be appreciated.

I’ve set up AirVPN which also uses its own DNS servers, I’ve also got pfblocker running on most of my vLANS.

When I’m on my AirVPN vlan on my ipad in Chrome without any browser add-ins I can tell that adds are blocked and it’s not AirVPN themselves.

When I’ve run DNS leak tests they come out ok.

I’ve set up pfblocker and applied them to most of my vlans. Didn’t do anything special for the VPN.

Perhaps check your rules, the pfblocker installs itself as the first one.

The firewall rules look fine (they’re at the top of all my other rules), pfblockerNG appears to be enabled and configured. Not sure what else it could be.

There’s a thread on reddit with someone with the same issue.

Out of curiosity I’ve inspected my settings in Firewall > pfBlockerNG > IP under the IP Interface / Rules Configuration section for Inbound Firewall Rules I’ve only selected WAN and for Outbound Firewall Rules I’ve only selected my vlans, interestingly I’ve not selected my AirVPN WANs.

It has been a while since I set this up, I failed to document my steps, perhaps give these settings a go.

I also notice that under MaxMind GeoIP configuration I’ve entered a key, I seem to recall the need for registering to use certain lists.