PDFs don't print or print extremely slowly when connected to UNIFI APs

This has been a weird ongoing issue for a client of mine.

They are able to print anything, any kind of document or photo from small to large file size with no issue. But PDF’s when either the computer or printer are connected to WIFI stall out error out or take 25 minutes to print. Even a 3 page PDF might take 15 minutes if it works at all.

If both clients are wired on LAN this isn’t an issue. If a WIFI client prints something that isn’t a PDF this isn’t an issue.


printers are all various models of HP,

network switch is a UNIFI Switch 16 POE.

I have tried the generic Windows driver and the official HP drivers on every client

I have tried printing from Adobe Reader, Edge and Firefox with the same result.

All clients are running Windows 10.

The clients are able to get full speed on wireless speed tests so it doesn’t seem to be that there is a more signal than bandwidth situation.

Unfortunately the router at this location is manged by another group so I don’t have any access to it but I don’t think the router is a cause because everything works fine with a hardline connection and all the clients are on the same subnet.

I’d love any insight that anyone has because other than narrowing it down to PDFs I can’t seem to figure out why its happening.

How big are the PDF’s you are trying to print?

Are the wired and wifi on the same network - both get an ip in the same ip address range.

If the printer on the same network ?

Yes. All are on the same network. Same /24 address space. The wifi is an extension of the same wired network that the printers are on.

It can be any size of PDF. Even small file size 1-2 page PDFs cause the issue.

Are you using a standard IP port for the print driver or a WSD port? Some copiers/printers really really hate trying to driverless print PDFs. I know you’re using actual drivers but if you’re using WSD ports, try and change 'em to Standard TCP/IP ports.