Package manager hangs

pfSense version 2.4.5-RELEASE-p1

Attempt to upgrade avahi from “installed packages” screen. Get page with “confirm” button, then page with

Please wait while the update system initializes

where it hangs forever.

same with other installed packages when I attempt to upgrade


Maybe install from command line?
Have you tried rebooting?
Have you tried removing a package, then reinstall it?

I don’t know how to do updates from the command line.

I tried re-booting. Didn’t help.

remove/reinstall would have the desired effect since the reinstall would grab the newest version. But it wouldn’t solve the update issue.

Very strange - woke up this morning and package manager says everything is up to date. Go figure.

Updating from the command line requires SSH access, so you’d have to enable that. Then, you’d run this command…

sudo pkg update

Thanks Sean. Enabling SSH I do know how to do :slight_smile:

1 Like

@mjstraw - great. It is good to have that option in your back pocket. Make sure not to expose SSH to your WAN port. If you do, make sure you connect with SSH keys and turn off password logins. Glad to help!