OpenVPN Wizard + OpenVPN Client Export Not Working

Hello.

I’m attempting to setup/configure OpenVPN on a fresh pfSense installation following this guide: Tutorial: pfsense OpenVPN Configuration For Remote Users 2020 - YouTube

I’ve gone through the OpenVPN Wizard which seems to function as expected. Once the Wizard has completed, I go under the “Client Export” tab to download the file necessary to input into the VPN Client I’m using (Viscosity), however, I don’t see any files to download. (GIF of my dashboard is below)

Can someone point me in the right direction on how to resolve this, I’m stuck and not sure how to move forward. I’ve already attempted to re-install pfSense, and have tried re-running the wizard but I never seem to get any files generated to download.

Troubleshooting Update:

  • When I connect via Ethernet into my network and then try to access via OpenVPN, I can see and access servers (LAN), however, I’m not able to access the internet.
  • When I disconnect the Ethernet and attempt to access my network via OpenVPN I’m unable to connect via Viscosity.

I’ve attached my current Firewall rules as well.

OpenVPN pretty much works without too many issues.

I’d guess you have a config error, you just need to go back and check step by step.

I’ve already tried that.

If you have installed pfsense2.5 there are changes to OpenVPN which may differ to prior releases, so the guide might not be an exact fit.

Ok - doesn’t really give me much direction though.

Under the OpenVPN settings check that you have “Certificate Depth” set to “One (Client+Server)”

Try creating a new user in System > User add a username and password, click ok. Then go back, edit your new user, now select the option to create a certificate.

Just recreated your problem when I created a new user but then the certificate in the Certificate Manager.

Looks like my settings were already configured for "One (Client + Server).

Ok, this got me a little further.

  1. I created the new user w/ certificate and now if I’m hard-wired into the network I can access via OpenVPN and I’m also able to access the internet.

  2. However, when I disconnect the ethernet cable and connect via Wi-Fi to a separate network, I’m unable to access the previous network via OpenVPN, which is the functionality I need.

Any thoughts on why I wouldn’t be able to connect when on a separate network, I’m unsure how to proceed.

It’s just another network, so OpenVPN needs rules to see whatever network you want.

My rules for OpenVPNs are not dissimilar to my vlans.

I’m still very new to this, so I’m not sure how I would go about opening the firewall up. My end goal is to allow my laptop to connect to my home network no matter where I am in the world.

here are my current firewall settings:

Any help is greatly appreciated. Just to make sure you’re on the same page - If I’m hardwired into the network everything is fine and works as expected. But anytime I try to access the network remotely I’m not able to via OpenVPN/Viscosity.

Are using a DDNS or is your WAN IP static ?

ummmmmm where would I check that - I want to say it’s static, but I could be wrong?

I’m getting the following from the client logs: