Openvpn on phone - zoiper not connecting


#1

Hi,

I have set up an openvpn server (following Tom’s video of course) to have my mobile phone get safely on my home network when I’m out of the house …

All seems to be working fine EXEPT FreePBX … it doesn’t want to register the Zoiper when I’m connecting through the VPN … when “normally” connected (from home, using the Wifi) it immediately connects … very strange …

All the other things I tried through the VPN do work (surfing to internal IP’s, connecting to my Domoticz server using their phone app, …) which proves that the routing is correct, no ?

Have I done something wrong ?

Also, I need to make a second VPN user, pointing to a server on it’s own VLAN (for an outside developper to install some stuff on it), so I wonder, do I only need to make another user on my already existing openvpn server, or do I need a new (second) instance of openvpn WITH a new user ?


#2

My OpenVPN is still using UDP but one of the things I had noticed is that using TCP instead of UDP for the SIP traffic solved connection dropping while using Zoiper on my phone.


#3

it’s not dropping, it’s just not connecting at all …
it’s perfectly connecting when I’m on the Wifi (local, so without VPN), but not at all when I’m out of office (through the 3G of the phone via the VPN) …

very weird …

and … I tried changing it to TCP, no solution …


#4

Check the routing to make sure it has a proper path back to the server.


#5

Yes, makes sense … I will certainly have to look into that, because when on the VPN I can reach all the other internal “websites” in this subnet (XOA, home automation, Unifi controller, Synology nas, PFsense, XCP-ng, TPlink switch, …) but NOT the FreePBX address (neither surfing to the admin console nor registering the extension with Zoiper) … very strange …

Would that be a setting in FreePBX or in PFsense ?


#6

Got it !

I needed to set the 10.0.0.0/24 subnet as “trusted” in the FreePBX firewall …

I thought my phone would be in the 192.168.1.0/24 subnet (because that’s what I told PFsense the “IPv4 Local network(s)” to be) but it apparently acts as 10.0.0.0/24 because that is the “tunnel” network …

Now everything works !

Thanks for the help