OpenVPN on pfSense won't connect, stuck with reconnect AUTH_FAILED... NordVPN? [SOLVED!]

I’m seeing a fair number of issues related to OpenVPN, from users who may have updated pfSense from 2.6 to 2.7. I’ve just made the jump myself because I was having issues with my OpenVPN clients… stupid reason for an upgrade I know.

Anyway… the issues I was having with OpenVPN have been going on for a little while. For a few months, the only really symptom was that on the pfSense’s Gateway widget on my dashboard, my OpenVPN clients have had their status stuck as “unknown”. But up until a week or two (in hindsight), there was no other discernable repercussions beyond that. Then over the last week or two, I’ve noticed that the RSS feeds that my torrent client uses have not been working. The torrent client is routed via the OpenVPN clients. Torrents were still downloading though. At this point, I’ve got to hold my hands up an admit that it turns out my torrent client was connected to WAN! So whoopsie-daisie.

The torrent client in question is Deluge, which I use in a client+server config. Such a config has a weird and rather unexpected quirk in that, when you’re using a client connected to the server to access the RSS feeds, the RSS feeds are fetched via the internet connection of the client device rather than the server’s connection.

So I tried connecting to a VPN from my desktop but it kept on rejecting my credentials. Despite the fact that I could use the exact same credentials to login to my VPN provider’s website. Just to rule out any potential issues with my password, I changed it, updated my OpenVPN clients on pfSense, but still… no dice!

Then I stumbled upon a thread on the Netgate forum…

If any of this sounds familiar then let me ask you one question… are you using NordVPN?

                            **The Solution**

It appears that NordVPN, in their infinite wisdom and without notifying us plebs users, changed the way OpenVPN authentication works… at least I think they did. If I’m wrong, then I apologise to NordVPN but if I’m right… then NordVPN can get bent.

Here’s the Netgate forum thread in question. I’m going to quote the solution in order to spread the good word but all credit and a my thanks goes to the user, Motleycru.

NordVPN issue solved
Yesterday (6-28-2023), my Glinet AXT1800 stopped connecting with the same “Auth Failed” issue in the log file. I found the solution to be:

  1. Disable the OpenVPN at the dashboard (to gain internet access)
  2. Go to NordVPN website and log in
  3. Under accounts - Services - click NordVPN
  4. Click - Set up NordVPN manually - at the bottom right of the page.
  5. You will receive a verification code in your email that you use for NordVPN services. Type the code in the popup window the preceded the email check.
  6. Copy the credentials using the “Copy” buttons on the right for your new encrypted user name and password in the OpenVPN Client settings.

You will now be able to connect again