OpenVPN Doesn't Work In Latest Version of Pfsense (Solved)

Hello.

Can someone help me, I’m trying to setup ExpressVPN on my pFsense box version 2.7.0 and it doesn’t work whatever guide I follow for it.

I either get (pending) for hours or when I enter custom options I get “Unable to contact daemon pFsense openvpn”

So, either something is broken in the current version or ExpressVPN doesn’t work on pFsense.

If anyone has any ideas on why this is the case or uses ExpressVPN please let me know or guide me on how to get it working.

I have never used ExpressVPN so I am not sure what changes would be needed compared to using PIA as I did in this video:

I’ve followed that tut, however still doesn’t work. There might be a problem with OPENVPN in the latest version of 2.7.0 as I’ve tried it in OPNSense and i’m able to get remote IP but do prefere Pfsense.

I’ve followed their guide here: https://www.expressvpn.com/support/vpn-setup/pfsense-with-expressvpn-openvpn/ But that doesn’t work either.

edit: I’ve now managed to solve the issue.

I’ve encountered the same problem. How did you end up solving it?

I’ve got this same issue too. How’d you end up solving the issue?

I got it working, running 23.09.1 release. I followed Tom’s video here in principal here: https://www.youtube.com/watch?v=ulRgecz0UsQ

For the config settings I did follow article here: https://www.expressvpn.com/support/vpn-setup/pfsense-with-expressvpn-openvpn/

I had to change a few of the custom parameters mentioned in the above article. Here’s what mine looked like.

fast-io;persist-key;persist-tun;remote-random;tls-client;verify-x509-name Server name-prefix;remote-cert-tls server;key-direction 1;route-method exe;route-delay 2;tun-mtu 1500;cipher AES-256-GCM;auth SHA512;fragment 1300;mssfix 1200;verb 3;sndbuf 524288;rcvbuf 524288