OpenVPN and PFsense

Hi really odd issue.

DHCP Range: -
Static IP: to

I have set up OpenVPN on PFSense and it is working perfectly. I can access all my local devices on the static and dhcp range with no issue. however.

1 device on the static range (Raspberry Pi4) is not accessible. there is no firewall on the Pi and i can ping it if im on my network. if I go through the vpn i cannot access it but everything else i can.

really odd…

Check to make sure the Raspberry Pi has a default gateway.

When I run:
ip r | grep default

I get:
default via dev eth0

What OS are you running on it? If it’s Linux I would expect ip tables to be running and would take a look at that. Also, maybe try to ping device connecting via VPN from your Pi. Check firewall logs to verify traffic flows.

I am using DietPI (Debian based distro); there is no firewall on the system and I have also tried pinging the the device while connecting to the VPN.

OK I found out what the issue is; im using a software called dietpi-nordvpn this uses openvpn which is stopping me from accessing the device while connecting to my pfsense using openvpn.

just got to figure out how to pass my connection through lol


OK found what I needed.

ip rule add from x.x.x.x table 128
ip route add table 128 to y.y.y.y/y dev eth0
ip route add table 128 default via z.z.z.z

Where x.x.x.x is your devices IP, y.y.y.y/y should be the subnet of your devices IP address, eth0 should be your devices Ethernet interface, and z.z.z.z should be the default gateway.

1 Like

I too have the same query regarding this.The informations are illustrative and brief.I have tried out that .I have following two queries in this trail that I have setup my router to create a OpenVPN connection and I have installed the OpenVPN app on my Samsung Android phone. Uptil this it worked out fine.
Now I just want to view my cameras using the iVMS-4500 app on my phone, while I’m on the OpenVPN connection. But I don’t know anything about what information I have to enter into the app.I have thought that I can choose between HiDDNS - IP/Domain - IP Server, but I think I have to use IP/Domain.
But,when I selecting the IP/Domain, I entered the IP of my camera ( in the adresse field, and the portnumber in the port field, and then username and password. But it does not work.And secondly,I am unable to setup VPN server In my Arlo pro 2.Suggest us what to do regarding these garmin map updates free download 2019 for the ultimate resolution.