Not getting IP's with Unifi Nano AP

I have been working on setting up my first home lab. Quick run down.
Pfsense xg7100 -1u version
cisco catalyst 3650 switch
Unifi Nano AP

So the AP was up and running finally and I could connect to it but it will not give out any IP address’s . Currently the AP shows disconnected which I also have no idea why. Last seen says never.

So I guess my first question is why would it just go from up and running to disconnected when nothing changed.

Next qestion is about when it was running why I wasnt getting any IP address from the IP pool.

Im trying to allow the PFsense to handle all the IP’s on the system. I currently have 3 print servers (little cheap io gear ones) with static IP’s connected to the switch and they all work. The AP also has a static IP which does show on the AP Controller. So It seems like the switch is passing the IP’s to the devices but when the AP was connected no devices were getting anything from the IP pool.

I am new to all the hardware I have and I am figuring out everything as I go but here but the cisco switch has been a bit of a challenge as I have found that not all commands work with all switchs etc.

I currently access the switch via the console port

Any advice would be appreciated or if you need any additional info just let me know.

1 Like

Does the Nano work if you bypass the Cisco?

Dumb question perhaps, I know you say it was running, but did you initialize and set-up the access point first (properly) with a controller?
If the AP is not initialized and set-up properly the device stays in factory default (derp) mode and won’t work at all.
I have tried initializing devices by using the phone app, and found it to be really unsatisfactory in addition to the phone interface also not being to my liking. The stand-alone cloud key gen is my go-to, worth while if you intend to buy more UI stuff.
I complained to UI’s dev people about the set-up woes but it’s a lot like complaining to the military, pointless IMO.

I’ve hooked up some mish-mash stuff with unifi AP’s and they seem to get the DHCP lease just fine. When i first had this stuff it took a few re-tries to get it to work right.

Additional thoughts:
The settings that UI devices tend to go by is when they are not receiving a DHCP lease or detecting the router (however UI does it), they do not permit you to connect to them. I have mine set this way.


I currently have an Asus wifi router configured as a hotspot connected directly to the pfsense box and its working fine.

I actually just picked up a cloud key gen 2 plus. Went into the AP via terminal and reset it and adopted it to the cloud key. Everything went smooth but the AP is still doing the same thing. Wont allow the clients to get a IP address

The cloud key is also connected to the switch.

Everything (3 print server modals, cloud key, and AP) all have static ip address I setup with the PF sense box and everything works great. Only thing is the AP just wont assign IP address.

Either a setting is wrong (although I doubt it), the software on the AP is buggy or you got a bad access point.
I have never had an issue with DHCP not issuing an IP. I am using an asus router as the device providing NAT & DHCP for now but plan to migrate over to a permanent solution like you did but haven’t decided as of yet if it will be PFSense or something else.

This a screen shot of an AP from my management page. Is your AP getting an IP from the pool?
What model of software is it running?

Tom was asking/suggesting you try connecting the unifi access point directly to an open port on the PFsense box to see if it works without being connected to the catalyst.

Alright. Really sorry it took me so long to respond back. I finally was able to get some time to work on this. So… here is the newest rundown.

I moved the AP and cloud key off of the cisco switch and onto the PF Sense 7100 -1u.
1.I setup a new interface vlan
2. Setup a interface switch vlan 7 8 9t 10t
3. Assigned the switch ports 7 8 to that port vid
4. Assigned interface assignments to optX, then enabled interface
5. Enabled that interface with static IPv4, with a new /24
6. Went into DHCP server and enabled DHCP with range 100-200
7. I have both the AP and Cloud Key static IP’s

  1. On the unifi side I reset the AP to factory
  2. I created a Network with the matching vlan id as in PFsense
  3. I created this network with password in the wifi tab.
  4. The Cloud Key adopted the AP with no problem. The stais IP is correct for both devices. At least the cloud key says the ap has the correct IP address.
    I have strong sigtnal and the down link and uplink are showing kbps of data passing.
    5 firmware is updated for all devices.
    Ring on AP is Blue.

The wireless network shows on my phone and when I try and connect to it, I get obtaining IP and then the network drops. Same with my pc.

I was having this issue with LRs. Apparently it was a firmware bug (I had a site with 6 nanos, 10 LRs, & UAP-AC-M-PROs and the LRs wouldn’t hand out IPs), been banging my head against the wall thinking it was a DNS/firewall policy issue.

A reddit user confirmed it was a sync issue with the firmware, big thread here

Firmware 5.43.38 fixed the issue, been going on 3 weeks without issues.

I am kind of at a loss.

I looked over the redit post and tried a few things like setting a group keyregen.

Tried giving the AP an IP from DHCP instead of static and that didn’t make a difference. I left it as DHCP for now

For Network DHCP Mode I tried both DHCP server and None options in the unifi software for the AP and nothing there. - Im leaving it as none for now.

im missing something somewhere I just have no idea what.

It should be fairly simple unless you are new to cisco. Tom has plenty of videos on this working in Pfsense you may want to revisit those or use a dumb switch into the pfsense to confirm its working at all. As far as the cisco goes make sure your uplink port to pfsense is a trunk port as well as the port that the AP is going to be plugged into.

Ubiquiti equipment can be defaulted via ssh or the reset hole.

I would just start fresh at this point. default everything. confirm everything works with a wire first then plug the AP in and start that whole deal. start with a flat network just see if your equipment is good and stable.

So I actually removed the cisco switch all together and connected everything directly to the pfsense box. Gave them their own vlan and followed the tutorials tom has put out.

I’m going to need to order a unmanaged switch just to do that but your right. At this point I am almost thinking its a hardware issue.

I have defaulted this equipment so many times at this point I am doing it in my sleep.

If you use an unmanaged switch it may not pass the VLAN traffic.

Nevermind. After 5 months I figured it out. I had to add the tag to the Vlan on the port in PFsense. I remember I tried this in the past and it didnt work but whatever its working now.

No I didnt. Well it worked for a little while anyway. When I made the port a tagged port in my Interfaces/Switchs/Vlans. I was able to get IP’s and had a few devices connected and working. I leave and come back and now the Nano is red dot and keeps going orange.

So. I unplugged my cloud key and the AP and let everything power down. I then assigned my AP a static IP in PFsense. When I turned everything back on the AP would not take the new IP. I shut off the Tagging on that port and the AP took the new static IP right away and the device status turned green. buttttttt… Its back to the original problem of not assigning IP’s to my devices.

I turned tagging back on that same port and the AP is staying green for now and my devices are connected and everything is working fine again. For Now!