Noobish 4 port NIC on pfsense question

hi new to the forum but i have been watching the channel for awhile now. i bough a HP elite desk 800 SFF with 4GB ram and an I5 CPU. Also bought a 16GB sata drive and an intel 4 port NIC card (SEE pic for model number). tried to install pfsense it got stuck with an error

EEPROM Checksum is not valid
ISD1_ATTACH_PRE failed 5

i used a LMDE 6 USB stick and booted into a live session

the NIC card shows up in the live session but only 2 out of the 4 ports are showing up.

i found another post on this forum

showing a link to intel’s driver site.
i tried to figure out what to do from there but i am lost

i pulled the card and installed pfsense without it. everything went fine and installed correctly using the motherboard NIC

shutdown and installed the 4 port card gives me the same error

also slow as molasses on the cold a day like the one we are having here in new england at this moment.

not sure what to do here any help would be greatly appreciated.

Hi @sirstabbybeard,

Welcome to the forum.

In my earlier post, my issue was related to the vendor firmware on the NIC stopping the freebsd driver from working correctly. I found a few posts from people on how to use the intel firmware and cross-flash (change the firmware from the vendor to the intel version) but (and I’m not an expert) - there were lots of cautions about cross-flashing and the potential to brick the NIC - luckily that didn’t happen in my case.

A quick search for ‘cross flash NIC firmware’ will yield you a few posts on that topic.

I’m not familiar with the error but it seems strange that two of four ports on the same card aren’t working, in my limited experience its usually all or none. Have you got a pc you could chuck the card in to see if they all work there? I’d start by discounting it isn’t a bad card.

Hope this helps,


I’ve got a 4 port NIC in my Proxmox box and I’ve seen that not recognise 2 ports on occasional updates. However, if you load Linux onto a USB stick and boot up from it, you should quickly find out if all 4 ports are recognised or not.

Perhaps the card isn’t seated properly or your wires … usual swaps you can do.