No Internet on Pfsense

Hello everyone,

New to Pfsense here. I cannot connect to the internet via Pfsense for reasons I do not understand even after consulting the troubleshooting guide available from Netgate.

Specifications for the router:

  • Motherboard: Biostar JH4125NHU updated to the latest BIOS
  • CPU: Intel Celeron J4125
  • RAM: 2x4Gb DDR4 Corsair 2666
  • SSD: Team group Nvme SSD 256 Gb
  • NIC: Intel I350-T4

Pfsense version: 2.6.0, installed using auto-zfs and GPT partition.

Interface and firewall rules are practically a carbon copy of Tom’s 2020 pfsense guide.

Things I checked on the Pfsense router:

  • Unchecked disable rfc1918 and bogon
  • For LAN: Action= Pass; Protocol=Any
  • Outbound NAT set to automatic
  • Nothing on Floating and WAN
  • Pinging yields 100% Packet loss.
  • Trace route only managed to ping, and then nothing.
  • System Logs show “WAN Default deny rule IPv4 1000000103” and “WAN default deny rule IPv6 1000000105” but I was informed that these are normal.


ISP-provided fiber optic router (Fiberhome hg6243c set to bridge mode) > Pfsense router

  • Igb0 WAN port is connected to the ISP router port set to bridge
  • Igb1 LAN is connected to my laptop for setup

The plan was to connect my Unifi switch and access points to the Pfsense router, but since I cannot get internet via the Pfsense router, they are currently plugged into the ISP-provided router. These access points work fine and can access the internet.

Another thing to note is that when the ISP router is in bridge mode, if I connect the LAN cable from the Pfsense router to my Windows 10 laptop, it would show the No Internet Icon on the bottom right corner. But if I don’t use bridge mode, my laptop would show the connected via ethernet icon, even though I still cannot access the internet.

Below is the screenshot of the pfsense web interface and the settings on the ISP router.

I am at a lost. Any help would be appreciated. Thank you.


  1. Is there a way to configure the HG6243C to allow pfSense to retrieve a public IP to eliminate double NAT?

  2. What does your static routes look like?

System → Routing → Static Routes

You might need to add one to route → WAN_DHCP

  1. Can you disable NAT on one side?

Did you uncheck blocking private networks?


  1. I do not know for sure. Could you tell me how I would do that? Maybe not for this specific device, but in general so I know what to look for?
  2. I checked, and apparently there is no static routes set up
  3. Not sure how I would do that either.

Thank you

Hi, yes I did. That was one of the first things I did

Okay, correct me if I’m wrong, but maybe I am having double NAT because my ISP provided router is not only running in bridge mode, but running router AND bridge at the same time. Does that make sense? Because when I try to configure bridge mode like in the screenshot, instead of changing the whole thing into bridge, I had to add another line and assign a port to bridge mode

If you take the PFSense out of the loop, and connect a machine to the ISP router do you get internet ?

Have you configured DNS servers on PFSense , check your settings as per screenshot - System - General Setup

Untick these options under your wan configuration

Yes, I can access the internet either by wifi or the ISP router. It’s the pfsense router that is having trouble. Those two bottom options have been unchecked already. And below is the DNS settings

Try changing your WAN port Interface config to DHCP and make sure the interface is enabled

Thanks for the reply, but I finally got it working. From the online manual I found on the internet, my ISP router is an ONT, not a ONR. Someone pointed out that it being an ONT means that bridge mode was unnecessary. So, first thing I did was plug Pfsense in without bridge mode.

But that was not the end of it because I could ping but was still unable to connect to the internet. Diving into the forums led me to this, which resolved the problem.