No internet behind pfSense Firewall

Hi All - I might be being stupid possibly, but really struggling to work this out.

I have pfSense installed on a VPS. The pfSense appliance can ping from its diagnostics menu, from the LAN interface.
However, my Windows VPS (also on the same private subnet, is unable to ping anywhere on the internet, not, not, or anything else public.

The Windows VPS can successfully ping the pfSense VPS ( The windows VPS is




I have tried the following:

  • Changing DNS Servers
  • Rebuilding the pfSense, even tried OPNSense
  • Tried disabling the ‘Block Bogon Networks’ option on the WAN interface
  • Tried disabling IPv6 on both pfSense and Windows
  • Tried manually creating an outbound NAT Rule (can’t be sure I did it correctly though)
  • Tried creating another firewall rule allowing all

The pfSense unit also sees the packets I’m sending (ICMP to

Any ideas/assistance would be greatly appreciated!! Pulling my hair out here…

I should note also that running a traceroute on the Windows VPS shows that it’s trying to route it through the pfSense firewall:

The Windows VPS also has a public internet interface, but I want to disable it and pass all traffic through the pfSense appliance, and then enable site-to-site back to the office.

If you did indeed create all the rules in pfsense as you said and it does not route, there may be some incompatibility with the VPS you are using and pfsense.

Hey Tom - that was my initial thought. However, I have successfully done it with the same VPS provider before. Unless for some reason or another, I happen to be on a different host with an issue or something…