to setup https on pfSense

I’m stuck trying to find steps for configuring a proper HTTPS SSL. I did have it configured once but have since forgotten the steps.
I have a cert, registered domain, from my Cloudflare account, with the Cert Acme / Certificates showing issued. I’m just trying to get away from having the “Not secure” showing, and understand the steps…again.

So all I need is a point in the right direction to get this set up correctly
pfSense 2.6.0

Thanks in advance

Hi @summersk59

Two things come to my mind:

  1. You didn’t select the correct certificate under “System / Advanced / Admin Access”…

  2. You are trying to access the interface by using the IP address instead of the corresponding domain name…

1 Like

Install the CA certificate on your system or in your browser and yeh… .make sure pfsense uses the actually certificate generated from that CA.

1 Like

Thanks for the quick reply,
I reset to ensure it’s the correct cert, I get the green box with the following message:

“The changes have been applied successfully.
One moment…redirecting to in 20 seconds”

I’m thinking, it’s not showing my domain, the IP? should it not have my registered domain?

So I’m still unable to use my domain, is there some documentation I can access, or which one of Tom’s videos explains this so that I can go back and recheck all my settings? I am sure there’s something I didn’t do correctly, and or missed a step along the way.

Thanks again for everyone’s help

Hello again, I went back to your videos ( youtube ) my answer was in your video about “DNS Host Override”. Once I did that, and tested with “dig” it all came together and works perfectly!

Thanks for everyone’s help!

1 Like