New Windows 11 build not recognising cloned drive from old machine

Morning all,
A friend of mine has asked me to build him a new computer to meet his MS Flight Sim needs.
The plan was to take the nvme from his old computer, clone it to another larger nvme…put it in the new machine and purchase a license for it. That way, avoiding the reinstall of all the applications etc.
I turned off bitlocker and ran Clonezilla. All went fine, no errors. Device to device. I left the partition sizes the same and was going to manually increase them in the new build.
I put the cloned nvme into a usb c caddy and can see all the files.
When I put it in the new machine though, it’s recognised in the BIOS but is ignored when it boots. It just goes straight into the BIOS.
I’ve tried the All-in-One system repair tool on the cloned the nvme, ran the fix bootloader app and it said it was successful but no difference.
Just wondering if I have missed anything? There’s the MBR but I’m pretty sure the fix bootloader will have addressed that.
I’ve resorted to AOMEI software for doing a fresh clone which is currently running.
I’m just wondering if I have overlooked anything?
Clonezilla usually does the job but admittedly this is the first nvme to nvme clone I have done.
Thanks for any advice or feedback.

I forgot to mention that I did do a fresh install of Windows 11 on the new nvme. It worked fine. I just want to avoid the installation of all the software again. Some of which he doesn’t have the original disks for.

Secure boot keys probably don’t match, therefore Windows refuses to cooperate. Just a guess but a pretty high probability. I wonder if you could fish the secure boot stuff out of the old board and copy them into the new board??? Might be worth a little looking around.

Is there a migration tool for Windows 11? Not sure if it would let you migrate the apps and settings over to a new computer, but might be another thing to look for. Looks like no but might be worth looking a little harder Windows Upgrade and Migration Considerations (Windows 10) - Windows Deployment | Microsoft Learn .

I disabled the secure boot before cloning so that should have circumvented the keys issue.

The Aomei software worked. Disappointing because I’m a big fan of Clonezilla. Not sure why it didn’t but couldn’t wait around to troubleshoot as my friend needed to be up and running.
I’ll probably do more testing the next time I have to clone Win nvme to Win nvme

I had similar issue and only way I was able to resolve that was to do a recovery on the duplicated NVME drive. Didn’t have to reactivate afterwards after the recovery.

@ebaker recovery using the windows boot media?

yes. I let the system boot up to the recovery screen and walked through that with the boot media

I tried that. It actually wasn’t recognising the NVME (from memory).
It with worked with the AOMEI software but I do need to test it again as I really like clonezilla.
Thanks for your feedback though :+1: