New pfsense router constantly drops the pppoe wan connection

Hi Guys,

I hope that someone can help me.

Because of a recent PSU failure of my current homebuild pfsense router i have desided to upgrade the router.
After research and be able to buy it for a realy good price i have bouth the way to powerfull SuperMicro A2SDi-4C-HLN4F :wink:
After setting everything up i notice that after a couple of minutes (between 1 and 5) the WAN connections drops for a second or 2 and then comes back.
This happens constant.

I’m sure that there is no problem with the network cable or pppoe settings because when i place the cable back in the old router there is now issue.

Setup settings:

  • Wan --> ix0.6 (getting internet trough vlan 6 and iptv trough vlan 4 of my internet provider, thats xs4all in the netherlands)
  • Lan --> ix1

Can anyone point me in the good direction where to look to resolv this issue?

I’ve already tried the following:

  1. Set Up manually the router based on the current working setup.
  2. Restore a backup of the working router and only changed the interface settings to the correct nic’s
  3. Default factory setup of pfsense.

If you need more information let me know.

Thanks in advance.

My first thought would be to switch the WAN to ix1 and lan to ix0 and see if the issue moves from PPPoE dropping to the LAN dropping.

Could be a faulty NIC / Interface.

This is the newer version of the firewall I run at work. The question I have is this, do you have any TCP offloading set? I get a lot of errors on mine when I set any of he offloading options. Switched to a PCIe card to fix this.

Not sure if it is the issue, but I would try not offloading any of those functions and see if the problems clears up.

Assuming this was working fine on the old system, restoring the backup and changing the network connections should have been enough to get you going again.

Thanks for both repsonse.

I didn’t change any off the default network config about offloading.
So i can take a look at that if something changes.

After that i change ix0 to LAN there is no problem with a constant ping.
So i guess it has to be something with offloading or that all 4 nic ports are on the same soc.

Last thing that i can check if something changes when i use ix2 or ix3 for WAN and ix0 or ix1 for LAN

But if you guys have another idea i will like to hear it.

Only other idea would be to install an Intel PCIe card and not use the built in NIC.

And which Intel PCIe would you advise?
It’s a home router so i don’t want to pay very much for just nic for the WAN connection.

Tom did a video on pfsense on the older version of that server, he mentions the model of card. You can get some of them for $20usd on ebay, cheaper if you only need two ports. I think the one I bought was Dell branded 4 port gigabit. If I did of again I’d get an Intel i350 or i340 based card, but those were double or more money.