Network Dropouts - Multiple times per day

I’m hopeful someone can make sense of these logs as im completely stumped now .
We have replaced all our networking equipment from Netgear to Unifi .
3/4 times per day our network drops for 15-20 seconds . We have recently replaced the firewall and i was hoping that would solve the issue but the issue still persists

I have pasted in the logs from the ProAggreation switch that is being used as the Top Level Top of rack switch , closest to firewall and servers etc . If anyone can spot anything in the logs i will be eternally grateful

May 14 14:09:13 ITCabinet4-ProAggregation1 user.info syslog: lcmd[1153]: lcmd.up date_uplink_port_id(): Reset uplink stat, uplink port 1 → port 29
May 14 14:12:42 ITCabinet4-ProAggregation1 daemon.info mcad: mcad[2850]: ace_rep orter.reporter_json(): immediately send user inform packet
May 14 14:12:55 ITCabinet4-ProAggregation1 daemon.info mcad: mcad[2850]: ace_rep orter.reporter_json(): immediately send user inform packet
May 14 14:13:11 ITCabinet4-ProAggregation1 user.notice syswrapper: [state is loc ked] skipping mca-send-inform
May 14 14:13:15 ITCabinet4-ProAggregation1 user.notice syswrapper: [state is loc ked] skipping mca-send-inform
May 14 14:13:19 ITCabinet4-ProAggregation1 user.notice syswrapper: [state is loc ked] skipping mca-send-inform
May 14 14:13:20 ITCabinet4-ProAggregation1 user.info syslog: mca-monitor[2968]: mca-monitor.do_monitor(): mcad.checkin is 17 ago (max=420)
May 14 14:13:23 ITCabinet4-ProAggregation1 user.notice syswrapper: [state is loc ked] skipping mca-send-inform
May 14 14:13:26 ITCabinet4-ProAggregation1 daemon.err mcad: mcad[2850]: ace_repo rter_trsp_curl.check_multi_info(): inform failed with curl code 28
May 14 14:13:26 ITCabinet4-ProAggregation1 daemon.err mcad: mcad[2850]: ace_repo rter.reporter_fail(): Timeout (http://192.168.170.240:8080/inform)
May 14 14:13:26 ITCabinet4-ProAggregation1 daemon.err mcad: mcad[2850]: ace_repo rter.reporter_fail(): inform failed #1 (last inform: 43 seconds ago), rc=4
May 14 14:13:26 ITCabinet4-ProAggregation1 daemon.info mcad: mcad[2850]: ace_rep orter.reporter_json(): immediately send user inform packet
May 14 14:13:31 ITCabinet4-ProAggregation1 user.notice syswrapper: [state is loc ked] skipping mca-send-inform
May 14 14:13:31 ITCabinet4-ProAggregation1 daemon.info mcad: mcad[2850]: ace_rep orter.reporter_json(): immediately send user inform packet
May 14 14:14:13 ITCabinet4-ProAggregation1 user.info syslog: lcmd[1153]: lcmd.up date_uplink_port_id(): Reset uplink stat, uplink port 29 → port 1
May 14 14:29:13 ITCabinet4-ProAggregation1 user.info syslog: lcmd[1153]: lcmd.up date_uplink_port_id(): Reset uplink stat, uplink port 1 → port 29
May 14 14:33:20 ITCabinet4-ProAggregation1 daemon.info mcad: mcad[2850]: ace_rep orter.reporter_handle_response_json(): cfgversion: 6985332837059632 → c4435b492 e4798c4
May 14 14:33:20 ITCabinet4-ProAggregation1 daemon.info mcad: mcad[2850]: ace_rep orter.reporter_save_config(): Saving stun_url as stun://192.168.170.240/
May 14 14:33:20 ITCabinet4-ProAggregation1 daemon.info mcad: mcad[2850]: ace_rep orter.reporter_save_config(): Saving mgmt_url as https://192.168.170.240:8443/ma nage/site/default
May 14 14:33:20 ITCabinet4-ProAggregation1 daemon.info mcad: mcad[2850]: ace_rep orter.reporter_handle_response_json(): [setparam] applying new system.cfg
May 14 14:33:22 ITCabinet4-ProAggregation1 user.notice syswrapper: [apply-config ] using fast apply
May 14 14:33:22 ITCabinet4-ProAggregation1 user.notice AxBpzmkTn: syslogd argume nts changed, sending SIGTERM to syslogd to force config reload

This looks like port flapping or your uplink device is having issues talking to the switch. Do you have the firewall directly connected to the agg switch?

Have you tried using a different cable?