Netgear managed switch vlans not working

I am trying to configure a vlan for my xbox using a netgear gs305e managed switch, and cannot get the switch to put the xbox on the xbox vlan, the vlan group is set to 2 in the switch vlan settings and the vlan id in pfsense is set to 2 as well. I have the dhcp server setup for the vlan but the xbox still gets an ip of when the ip range for the vlan is 192.168.20.xx. This was using the tip someone commented on my last post of setting the vlan id on the switch while it was unpluged form the pfsense server and then setting up the vlan on pfsense. Not sure what im doing wrong as im rather new to pfsense but i doubt theres anything wrong with my hardware.


Please share screenshots of any/all VLAN related pages in the Netgear.

1 Like

Would resetting the states in pfSense be helpful?

How are you configuring it? The netgear switches have basic vlan settings and advanced.


i am also getting this notification in pfsense but those are not even the ip’s im using for the vlan:

i am using the basic vlan settings

I think you should delete the XBOXES network and recreate it to get rid of that error. If the error persist then you have a corrupt config and may need to start over setting up PFSense from scratch.

Port 5 of the netgear is connected to the PFSense LAN? And in PFSense you are creating the VLAN on the same port as the main LAN?

I’ve used Netgear switches on vlans for a while and they are straightforward to set up but I believe you need to do things in a sequence for it to work. This week I set up a new pfsense box with vlans and a Netgear switch, these were my basic steps

  • connect to the pfsense box on it’s LAN port and configure the vlans etc. On my box I have 4 further ports which I use in a LACP lagg, this becomes my parent interface for my vlans.

  • on the switch I keep the first port as the default vlan 1 so I don’t get locked out of it. I create all my vlans (including a management vlan). I change the IP address of the unit to an IP address on my management vlan, there is also a setting under System > Management to enter in the management vlan ID (before you do this ensure you have one port assigned to the management vlan otherwise you will be locked out).

  • I then configure 4 ports for LACP, in your case you ought to just tagged the ports on each vlan, so for say ports 4 and 5 mark each with a T for vlan memberships.

  • Then in Port PVID I enter the vlan number for the port. If the port is tagged then I enter the lowest number.

  • Then I go back to vlan 1 and remove the ports from vlan 1 that have been assigned to other vlans.

Some other things I do is not to use vlan1, vlan2, vlan3 as these are defaults and number my management vlan 10 and the rest 20, 30 etc.

If you plug together the pfsense box together they should conmmunicate.

Then test out each port on DHCP to see you get an IP address.

I tend not to use the LAN on the pfsense box, it’s just there. You then need to have rules that allow you to view your various vlans in place.

Hi neogrid, I am hoping you can help:

  1. On pfsense, apart from the default WAN and LAN (, I created 4 more VLANs , one of them is a VLAN10 for trusted devices( I understand that I need to change the management VLAN ID to that of 10 and I can’t as it’s DCHP’'ed with address of How can I change this IP of Netgear to that of VLAN10?


I presume somehow you are restricted from selecting static IP in the switch ?

When I first started with pfSense and my Netgear switch I found that if I tried to configure the networking / vlans etc. via the switch on pfsense it would lead to all sorts of problems. Instead, I configured the vlans directly on pfsense, then configured it on the switch, then connected the two.

I’ve also run into issues when trying to change modify vlans on Netgear whilst connected to the network. When I unplug from the network, configure the switch as required then reconnect it works.