Netgate repository server certificate issues?

Hi all,

Just installed new lab 2.5.0 HA cluster and when tried to install some packages hit error in the UI. When tried via the console “pkg-static update -f” had some error related to their repository server and its certificate.

Blockquote
error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed:/usr/local/poudriere/jails/pfSense_v2_5_0_amd64/usr/src/crypto/openssl/ssl/statem/statem_clnt.c:1915:
Certificate verification failed for /CN=*.netgate.com
Blockquote

Then did curl and saw they have issues with their cert chain. Anyone had similar issues?

Blockquote
curl -cacert https://files01.netgate.com/pfSense_v2_5_0_amd64-pfSense_v2_5_0/meta.txz
curl: (60) SSL certificate problem: unable to get local issuer certificate
More details here: https://curl.haxx.se/docs/sslcerts.html
curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.

Blockquote

Just tested using
openssl s_client -servername files01.netgate.com -host 162.208.119.40 -port 443

and the cert was valid. Try their forums https://forum.netgate.com/

Seems it was temporary issue. No issues what so ever now.