Need help setting up Rasberry Pi rdp honeypot

Hey guys,

I’m following the page you guys recommended on HTGH14, and i’m stuck on step 4.

It’s saying to validate the files, but I can’t seem to find them or can work out how to do it.

Any help is much appreciated.

Keep up the great work!

I assume you are talking about this https://medium.com/@alt3kx/build-an-easy-rdp-honeypot-with-raspberry-pi-3-and-observe-the-infamous-attacks-as-bluekeep-29a167f78cc1
What is the exact error message?

Hi Tom,

Yes, that is the article. I can’t find the files it mentions to execute for validation

rdpy-rdpcredsspmitm.py
rdpy-rdpmitm.py
rdpy-rssplayer.py
rdpy-vncscreenshot.py
rdpy-rdpclient.py
rdpy-rdphoneypot.py
rdpy-rdpscreenshot.py
rdpy-vncclient.py

I ran the kali fix he mentions, but still can’t find the files.

I may be just a noob, but I’m hoping it’s more than that.

Maybe it dropped you into another directory, or the files are somewhere else?

Try:

pwd
(this tells you where you are, make a note)

cd /
(cd to root)

find * | grep rdpcredsspmitm
(search for rdpcredsspmitm)

If it’s on the system, that should tell you where it is. You can then cd into the location and continue the tutorial. =)

Thanks faust. I already tried the find command and tried it again with your tips and the files still can not be found.

I’d try to run this again: pip install rdpy

If you’re copy/pasting code from the webpage, sometimes things get missed/wonky due to carriage returns.

If that fails, I’d try this: pip install rsa pyasn1 and then re-reun the install rdpy line.

If none of that works, I’d wipe everything, re-download images, and start fresh.

My original install I downloaded the kali image from the offical website. Tried the image from the article link. Followed all the steps again, and same problem. Can’t find the files.

Do I need to manually compile the source code or anything?

Either there’s a step missing, or the “fix it” instructions should be run?

wget -c https://twistedmatrix.com/Releases/Twisted/19.2/Twisted-19.2.0.tar.bz2
bzip2 -d Twisted-19.2.0.tar.bz2
tar -xvf Twisted-19.2.0.tar
python setup.py install

If that fails, I’m outta ideas as the only RiP3+ I have is in my car.

That was the kali fix they mentioned in the article. It’s already been tried. Have you setup the honeypot?

No, no need for it here personally. I use my RPI3 for automotive media things. I do know they can be temperamental lil things, took me awhile to make it do what I wanted.