NAT rules with whitelist issue

I have created a NAT rule and also created an Alias with Cloudflare IP address for whitelist. I have also a DNS from cloudflare pointing to my pfsense (and proxied with Cloudflare), which looks like this:

Without the Cloudfare alias, i am able to connect even when the DNS is proxied … Any ideas or suggestions to get the whitelist to work?

EDIT: I have also tried using the Source on Any and port on Any and just using the Destination to use Alias with Cloudflare and the port number. Same issue - no connection.

EDIT2: I have also added IPv6 for, well… why the hell not at this point… still no conenction…

Your source cannot be the same as the destination.

Your source should be set to Cloudflare
Your destination will be set to the WAN address and the port, in your case 19132

then you set your redirect target IP to destination of your server and port 19132

Note: I wouldn’t set the source ports because they will always come in as random ports. You only need to define the destination port on your WAN address

That for you information. After more testing i found out i messed up the cloudfare proxy. When i tested I didnt gave it time to refresh back to proxy, so i got a false test.
Thanks again and I will know ill be using this whitelist soon.