NanoHD won't re-adopt after pi-hole issue

I have an issue with my Unifi NanHD.
After an update of my pi-hole, running on a raspberry pi, the pi-hile blocked a service "’, I’m not sure it is the source of the issue, but since then I noticed the problem.

I have a unifi switch (US-8-60W), with a NanoHD for about 2 years, without any issues. I’m running the controller in a docker container on my Synology disktation (on a fixed IP on, I’m limited due to my ISP provider, maybe in the futur I can run my own router).

Both unifi devices are running the latest firmware since today and the controller version is 6.0.43. I noticed last week the NanoHD was blinking white and showed up in the controller as not adopted. I disconnected it a few times from the switch by pulling the cable, but it will nog re-adopt.
I logged into the NanoHD via SSH en did set-inform. When I asked “info” it stated that there was an error with the inform server. But than after some days and a new set-infom it just states “not adopted”.

When I try to adopt it in the controller, it tries, but always fails.
Strange thing is, it just works fine, everybody can surf the wifi, but it just can’t control it in the euhm controller :slight_smile:

What’s going on and how to fix it?

UniFi does that as part of their stats collection system.

Ok, so that is not the cause

Anyone any idea what to do? I only have one AP, so if I loose connection/wifi there will be very angry (little) people here at home :smiley:

Have you tried manually updating the firmware to the latest version?

just did (googled your video about it, thanks), very strange because I thought I did it yesterday via the controller interface.
After the upgrade to 5.43.23 the inform was referring to http://unifi:8080/inform, so I did a set-inform to my nas, but now it states (once again): server reject

Maybe there are are issues using the older controller and the newer firmware. We are running controller 6.0.45 and not having any issues.

upgraded the controller, tried another adoption, still nothing
before the adoption the info of the AP says “not adopted”, during the adoption proces it states “server reject”, after it fails it states again “not adopted”
really confused

thanks for the help so far

I had an ap once get into a goofy state like this. All I could figure out was reset it and readopt. It has been working ever since.

Wish I could explain what happened.

just purchased a wall-HD (to extend range via meshing), just first hooked it up to the switch and removed the nano-hd (I don’t have a fixed wired connection to the switch and no laptops with an ethernet port).
After a software reset and removing the nano-hd, I just showed up againm provisioned the AP, updated it and problem solved.

Strange, but problem solved