Lets talk: TrueNAS Scale as the main system on bare metal. Virtualization, apps, shares

Hi there, how are you doing people?

I was installing new system and was deciding between TreuNAS Scale, Proxmox and Unraid.

I decided to go with TrueNAS Scale because I am long term fan of ZFS. I was having my own home server based on debian with zfs for many years, then I switched to truenas core (which was great as far as storage goes but the story with apps and vitualization wasn’t so great).

My needs are:

  • solid storage and network shares with snapshots
  • Windows Server in VM for hosting some asp.net core apps
  • Ubuntu Server in VM for hosting some linux services
  • Some “dockerized apps” like Syncthing, sonarr and similar, maybe some db

My feelings so far:
Installation of TrueNAS was easy and without problems.
Setting basic things like pool and dataset and users and shares… all very intutive and easy, I like the GUI. Sharing seems to work flawlessly.
I very much appreciate that they added 2FA auth option for admin interface.

Now the not so good parts - virtualization seem to be “rough around edges” … I spent whole day trying to figure out how to set the network interface so I can see from my VM (Ubuntu Severer) to my NAS and from my NAS to Ubuntu, and I still can’t get it to work :frowning: My Ubuntu can ping internet and my router but not TrueNAS and my TrueNAS can’t ping my Ubuntu.
This kind of took the enthusiasm away and it kind of ruined the experience.

Then I tried to play with the apps. I am not big fan of Kubernetes, I hoped they would go with something like plain Docker + Portainer or something along the lines. I installed few apps from their official catalog, but I had some problem with Syncthing… something with permissions… I didn’t wanted to spend much time with it, so I dont know what went wrong exactly yet. Then I tried to install some torrenting tools from TrueCHARTS catalog… like Sonnarr + Transmission. But because of how kubernetes works, the containers dont see each other, there is some more involvmenet to get this working and at that point I just gave up…

What is your experience with TrueNAS Scale if you are also trying to use it for Virtualization and Containers, not just for storage?


I don’t recommend using TrueNAS Scale or Core for virtualization, I have never had a great experience with it, it’s very basic compare to other solutions. Being that Scale is so new I have not done much testing with the apps but dealing with permissions is always a learning curve.

Hmm… yeah I am afraid that it looks like the virtualization is not there yet… not on the level where it can be considered serious hyperviser…
But I was really hoping I can avoid combiding Proxmox and Truenas and just be happy with one system…

Maybe I will still give it a chance for a while and see how it goes… :slight_smile:

I brought up a Scale-on-bare-metal server in December, and as you said, the TrueNAS install was painless, it all just worked.

I have not tried the VMs, having read forum posts about the lack of polish, you are just reinforcing that view.

I am running three apps: Syncthing, Pi-Hole and Home Assistant.

Somewhat contrary to your experience, Syncthing has been working just fine for me, no permission issue that I’ve seen syncing up a Win 10 workstation, Ubuntu server, Fedora ws, Mint laptop and Android phone photos. It all just connected up and worked for me.

Pi-hole was very painless (I’ve got two Pi-holes, this app and a bare-metal pi version for comparison). I installed the app, copied my config from the rasppi and it worked out of the chute, but… Every time I reboot the TrueNAS app, it resets my upstream servers to quad9’s IPv4 ones. I have unbound running on another machine, doing the authoritative DNS for my home network, so I set it as upstream for the Pi-holes to get local name resolution, but every time I reboot TrueNAS Pi-hole, bork! I have to go to the configuration page and turn off quad9 and re-enter my local upstream. I’m not sure what’s going on, but I suspect that the local network is not up yet when the Pi-hole tests its upstream, so can’t see my local server, and resets it to quad9 by default. More investigation needed…

Home Assistant is a total mess. My inexperience with kubernetes means I can’t figure out how to punch through the k8s firewall, so HA can’t get access to the LAN to monitor stuff like router status. I did get it to pass-through a USB device, so I can see some Zigbee devices, but that’s flaky as hell (pairing things is really hit-or-miss, usually miss). I have HAOS in a VM on another machine and it suffers none of these issues.

Pi-Hole is something I want to run as well… When you get to the bottom of the issue please share your findings :slight_smile:

Well, since you asked, I spent some time on it today… :grin:

It was actually quite easy, once I started playing outside the app itself. I went to the TrueNAS three-dots dropdown on the app, got into Edit, went down to “App Configuration” and set the values for “DNS1” to the IPv4#port of my unbound server, and “DNS2” to IPv6#port for the second value. Restarted Pi-hole and everything was peachy. Re-installed the app, started it, still ok!

I thought that no external data leaked into the config, thinking that the internal state was the only place to set your upstreams, but no, that part is back in TrueNAS and not in the Pi-hole management.

1 Like

I was able to get the bridge for VMs working when using physical keyboard+monitor setup and their onscreen menu.

For anyone else having the same problem I will just post my steps here:

1 Like