LAGG - No Ports Visible to Add on pfSense SG4100

I have a new pfSense SG4100 setup and tied to my Unifi POE 24 Port Pro switch. I did check and my pfSense has the latest software version…and no, I have not upgraded my Unifi Controller yet…still waiting.

I want to setup LAGG between the two but when I go to Interfaces > Assignments > LAGGs in pfSense I don’t see any Ports available. The documentation says those pfSense Ports are probably used for something else but I cannot see them listed anywhere.

I do have several VLANS but they all use the same Port as the current LAN (#1). I have no other switches in the network, 2 NanoHD WAPs and about 20 persistent devices.

Is there a good way to troubleshoot and resolve this?

Best Regards,

Brian

Do you see the ports under “Available network ports:” in the menu Interfaces / Interface Assignments ?

It looks like you have already assigned the interfaces, hence they won’t show up.
However on my setup with LAGG, I can still see my WAN interface when I add another LAGG.

Double check your config.

Sorry for the delayed reply. I didn’t have a way to remote in to answer quickly but I just completed and tested OpenVPN to prevent that from happening in the future.

Also, it is an SG-3100…I guess I wished I had a 5100 but only wanted to pay a little more than the 3100 costs.

ThomasG - No I don’t see the ports under “Available network ports:” in the Interfaces > Interface Assignments menu.

Attaching screenshots below.

Here is a screenshot of my Dashboard with redactions as needed.

Hmm … think something is up with your LAN interfaces
image
Those white crosses don’t look good.

My guess would be that while you were setting up pfsense, you configured all your interfaces.

When I set up my box, during install I only assigned the WAN and LAN ports during setup. I configure the box on LAN, my other ports all come up as available for a LAGG.

Though perhaps the Netgate boxes have something special.

It’s easy to test, just take a backup, then reinstall pfsense configure only the WAN and LAN, then navigate to interfaces and see if you can then create a LAGG.

Thanks, I will give that a try.

The LAN ports on the SG-3100 aren’t really connected to the CPU the way the other interfaces are. There is only the single 2.5Gb/s “LAN” port, which is internally connected to a switch chip. Basically, there is a 5-port switch, with one port connected to the rest of the system and the other 4 on the front panel. Therefore you aren’t going to be able to set up LAGG the way you are trying to do so.
From here: https://forum.netgate.com/topic/138167/sg-3100-lagg/7

What you do is set two ports to the same VLAN configuration then, on the Interfaces > Switches, Ports tab you can click on the LAGG on each port and set an unused ID, Such as 1 on the LAGG ports.

Note that this is a Loadbalance type lagg, not LACP, etc.

1 Like

Perfect response Bruce. I wasn’t aware of this. I guess I will either have to load pfSense on my own device that has the multiple interfaces vs switched or spend the money for an SG-5100 which has the 4 independent 1 GbE ports I need or even better go to the SG-7100 and use the two 10 GB SFP+ ports to connect to the USW Pro-24-PoE. Thanks for the help.