LACP switch to server question

I’m looking into setting up an LACP lag on my netgear switch going to my server which has a quad nic. I’ve configured both the switch and server still having trouble.

My lag is part of vlan 20, the switch says that the port channel is up. The server however takes 5 mins to log on as it’s trying to connect to the network but failing.

Any clues as to what I could try.

I have tried making sure that speed and duplex match on both sides. I believe my ubuntu server config us correct. Not sure what else to try.

For my setup I had to make sure that the VLAN was added to each port before assigning them to a LACP otherwise the LCAP would not create and I could not add tags to a port on an LCAP as it would make not equal.

I am using a DGS-1100-24 swtich to a Intel quad NIC running pfSense.

1 Like

that was the first thing i tried, i had each of the ports already in vlan 20 and then on the lag pag vlan 20 set and it wouldnt work.
the switch is saying that the port channel is up but when i boot the server it takes 5 mins to raise the NICS and times out. i cant ping anything on it.


what OS are you running on the server? how is the server side configured?

Running ubuntu 16.04 followed the generic lacp setup from ubuntu forums, the servers saying the ports are up, port speeds and duplex same as switch aswell as mtu. I have ordered another card just to eliminate the card being the issue.

Any chance you can post an screenshot of what nm-connection-editor shows (I am assuming your running a GUI envrioment) and also what is shows for each of the interfaces under the General, Ethernet and Bond tabs for the interfaces as well

Are you absolutely sure NetGear supports LACP? From what I remember, LAG is not LACP. Perhaps you are better off with bonding mode-6 since the links are bound to the same physical switch?

Also, consider disabling spanning tree on these ports to make them come up faster since they are connected to a host and not another network switch.

Netgear do support LACP, although that interface looks like their old interface so it might be that model doesn’t, so it’s worth checking. I also seem to remember that the older switches used static aggregation by default and you had to tell them to use LACP/802.3ad, but I could be wrong. I would also try and get just 2 cables working to start with as I’ve had issues with more than 2 in the past when going to a server rather than a switch.

Hi guys sorry for the late reply, ive made some changes and now running Freenas instead. same issue, both devices showing as up but not communicating.

i now have another vlan defined in pfsense for just the servers and rules set in my main vlan to access it but still no joy.

the switch is a netgear gs724t and to my knowledge supports LACP, the Lag is set to LACP and is showing as up. in vlan settings ive pointed the lag to vlan 50 and set PVID of the lag to 50.

not sure what else to try shelving it for now until i get a firm understanfing of where i am going wrong and using just the 1gb link i currently have set for accessing it.

Have you tried setting up the lagg without a VLAN to see if you can get it working that way? then you will know if your problem is with the VLAN or wih the LAGG.

Asterra, no not yet trying to iron out my setup trying to escape the clutches of vlan and have a management interface instead that isnt vlan.